Stator or rectifier?


5 replies to this topic
  • ride4ever

Posted November 24, 2007 - 06:50 PM

#1

My '06 WR450 has killed 2 batteries. At least the kick starter brings it back. Once cranked, everything works (lights, computer, etc.) I can ride for an hour with no recharge on the battery. I measured the ohms like the manual shows for the stator which seems in spec. Voltage at the battery when running ranges from 9 to 11 volts. My guess would be the rectifier, but sometimes someone has seen other problems. Anyone have any clues?

  • SXP

Posted November 24, 2007 - 07:44 PM

#2

My '06 WR450 has killed 2 batteries. At least the kick starter brings it back. Once cranked, everything works (lights, computer, etc.) I can ride for an hour with no recharge on the battery. I measured the ohms like the manual shows for the stator which seems in spec. Voltage at the battery when running ranges from 9 to 11 volts. My guess would be the rectifier, but sometimes someone has seen other problems. Anyone have any clues?


Why only an hour? The condition of the battery should not determine how long you can ride as the ignition circuit is separate from the lighting/charging circuit.

Do you have a BajaDesign kit on your bike?

  • SXP

Posted November 24, 2007 - 07:46 PM

#3

Never mind. I see you meant that the battery would not charge even after riding for an hour. Doh!

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • tweav

Posted November 25, 2007 - 05:18 AM

#4

I have the stock rectafier off of my 2007 if you want to try it here's some pics . I used the two plastic wire ends other then that it's new

Posted Image

Posted Image

  • WR_Dave

Posted November 25, 2007 - 06:47 AM

#5

Sounds like the rectifier to me too. Obviously you have gone through the testing procedure outlined in the Manual? The manual says the charging voltage should be 14 - 15 volts DC at 5000 rpm. It says if the charging voltage isn't correct then test the charging coil and if it is OK then you need to replace the rectifier. Hope this helps and the manual for your bike is free online in the WR performance stickies at the top of the forum. Good Luck -- WR Dave.

  • Asgeir

Posted November 25, 2007 - 02:57 PM

#6

Do you charge the battery between rides ?

It is really hard for the charging system to bring a dead battery to life as it only makes 26 Watts.

Try charging the battery with a trickle charger that makes 1 to 2 amps and have it stay on for several days.

Then measure the volts output of the charging system (with a fully charged battery)




 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.