bad choke on new 07?


2 replies to this topic
  • tarmac_terrorist

Posted November 20, 2007 - 02:42 AM

#1

I went to start my 07 and went for the choke. I tried pulling the choke out but it will not hold open in the 'cold' position. It remains firmly in the warm position.

This is a brand new unridden bike. Any ideas as to why i cant open my choke?

Thanks

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • tweav

Posted November 20, 2007 - 04:09 PM

#2

I think if it were mine I would just take it off , to get a better look at it .most likley it just has a bit of corrotion or dirt in it making it stuck .take it apart and clean it .

  • tarmac_terrorist

Posted November 21, 2007 - 02:52 AM

#3

I think if it were mine I would just take it off , to get a better look at it .most likley it just has a bit of corrotion or dirt in it making it stuck .take it apart and clean it .



Thanks very much tweav. I spoke to a yamaha tech about this and he said much the same thing. He reckoned it was either internal carb corrosion or varnish from stale fuel. Im slightly miffed that this has happened. I'll try cleaning the part and swapping the fuel out for fresh and will add a fuel stabiliser.

Thanks for your time.




 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.