XR650L: no spark - where to start...


5 replies to this topic
  • bluerock5

Posted November 11, 2007 - 07:05 PM

#1

My 03 "L" has been running great - and suddenly - it won't start. The fuel delivery seems fine - but the plug has no spark. tried a new plug - no spark. Is there a weak link I should check out 1st - like the coil or pulse generator. Thanks for the help in advance......

  • cleonard

Posted November 11, 2007 - 07:13 PM

#2

The weak link on the 650L is the CDI box. It is a very common failure.

  • stepho

Posted November 11, 2007 - 07:16 PM

#3

my 03 cdi box went out a month ago.

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • martinfan30

Posted November 11, 2007 - 08:18 PM

#4

My 03 "L" has been running great - and suddenly - it won't start. The fuel delivery seems fine - but the plug has no spark. tried a new plug - no spark. Is there a weak link I should check out 1st - like the coil or pulse generator. Thanks for the help in advance......


good starting point...

take both wires off the clutch switch and ground them both. this bypasses all safety switches.

if you still have no spark then look at the cdi unit.

  • bluerock5

Posted November 12, 2007 - 05:51 AM

#5

Is there a way to check to see if the CDI is bad ie....can you use a meter on it?

Also, is there a good after market brand of CDI thats better than the stock Honda unit? Thanks...

  • martinfan30

Posted November 12, 2007 - 08:23 AM

#6

not really. all you can do is verify it has all the necessary inputs.





Related Content

 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.