Electric Output Stator for 06-07 YZ450F - UPDATE


98 replies to this topic
  • xcape

Posted February 02, 2008 - 06:07 PM

#61

http://www.vancouver...products_id=119

These guys do it all the time

  • William1

Posted February 02, 2008 - 06:18 PM

#62

They are just Trail Tech and Electrosport resellers, nothing new or unique there.

  • mrpink46

Posted February 10, 2008 - 11:29 AM

#63

Hi swatdoc, have you received and installed the moose stator, is it working??
Please let us know.
Thanks
Mrpink

  • swatdoc

Posted February 10, 2008 - 09:02 PM

#64

mr pink - i sound like a broken record, but it just keeps getting pushed back again and again. I'm just gonna stick with the electrosport unit I already have installed, and when/if the moose unit comes in, I'll have it as a spare.
This crap with moose has been VERY frustrating!
On a side note, the electrosport unit seems to be working fine with my 35 watt acerbis headlight and 1 watt LED tail light

  • akonibai

Posted February 10, 2008 - 10:35 PM

#65

mr pink - i sound like a broken record, but it just keeps getting pushed back again and again. I'm just gonna stick with the electrosport unit I already have installed, and when/if the moose unit comes in, I'll have it as a spare.
This crap with moose has been VERY frustrating!
On a side note, the electrosport unit seems to be working fine with my 25 watt acerbis headlight and 1 watt LED tail light


i thought that they only make up 2005, where did you get that?

  • swatdoc

Posted February 11, 2008 - 07:58 AM

#66

directly from electrosport.

  • akonibai

Posted February 11, 2008 - 04:07 PM

#67

directly from electrosport.



how much did you pay for it? do you have the contact person of electro sport?

  • swatdoc

Posted February 11, 2008 - 08:40 PM

#68

no specific person, just called the number from their website. I think it was about $200
be sure to let them know it's for an 06 or later yz450f MOTORCYCLE, and not the ATV

  • ca412686

Posted February 18, 2008 - 04:24 PM

#69

Im still waiting on my stator as well. Its suppose to be here this Wednesday! I got the DRC EZ wire kit installed and it works awesome. I was wondering what kind of voltage regulator people are using? I some use the trail tech, but are there others available???

  • swatdoc

Posted February 19, 2008 - 05:51 PM

#70

trail tech is what i'm using, but i'm sure there are others - just make sure it's a 12 volt and you should be OK

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • ca412686

Posted February 20, 2008 - 08:22 PM

#71

anyone know if a 02 wr426 regulator would work? I would think it s a 12v ac system since there was no battery....

  • wfo72

Posted February 26, 2008 - 12:19 PM

#72

I just called Electro Sport and tried to order one there on BACK Order for a month........Any further luck with the Moose one???? Or other suppliers??

  • swatdoc

Posted February 26, 2008 - 04:23 PM

#73

still no word on Moose - when it comes in it comes in. I would contact Lake and Trail and have them rewind your stock stator - that's gonna be the quickest way right now.

  • ca412686

Posted February 26, 2008 - 05:02 PM

#74

Ok, I called Electrosport as well and apparently a company bought up all the ones they had left in stock. They are suppose to be making a "kit" for the YZ. I talked to Parts Canada here, and there are 3 Moose ones in stock and I have my name on one. They said it will be here MArch 5th......we'll see!

  • wfo72

Posted February 27, 2008 - 04:32 AM

#75

Well I have paypal and would love to get my hands on 2 so if anyone runs across some let me know....Do you have the phone # for lake and trail?? Are they in USA????

  • wfo72

Posted March 05, 2008 - 06:27 PM

#76

Thanks ca412686 Its ordered and on its way from electrosport....They now have in stock but going fast.............Im so ready......I just bought a 05 yz250f supermoto....Its now back to dirt trim.....love it in the woods So now the 450 can be dedicated track supermoto and backroad destroyer !!!!!!! :thumbsup:

  • ca412686

Posted March 06, 2008 - 05:43 PM

#77

No prob.. I got mine all wired up and ready to go too. Lights installed, but nothing to power them....yet! I should have mine next week sometime they said.

  • wfo72

Posted March 13, 2008 - 05:50 PM

#78

mine is installed now im looking for a 12 volt reg and lights I checked it out its working and lights up a old headlight I had !!!!! Almost complete !!!:thumbsup:

  • swatdoc

Posted March 13, 2008 - 10:55 PM

#79

WFO - so which stator did you end up with?

Just finished all the wiring for my bike today - so I'm all ready to get my inspection in order to plate my bike!

  • wfo72

Posted March 14, 2008 - 03:03 AM

#80

Electrosport...is the one....





Related Content

Forums
Photo
Supercross

Wilson the Blue Privateer by jetfuel


Dirt Bike   Special Interest Forums   Pro Racing
  • Hot  50 replies
Forums
Photo

Megabomb Fitment by 288yz450


Dirt Bike   Make / Model Specific   Yamaha   YZ 400/426/450
  • 1 reply
Forums
Photo

James Stewart back on a YZ450F by YamaLink


Dirt Bike   Special Interest Forums   Pro Racing
  • Hot  47 replies
Forums
Photo

05 yz450f not fast enough by RedeyeYZ


Dirt Bike   Make / Model Specific   Yamaha   YZ 400/426/450
  • Hot  38 replies
Forums
Photo

Chubby dad, looking at bikes , First trip to the orange/black forum ! by Slow_ride


Dirt Bike   Make / Model Specific   KTM   250-530 EXC/MXC/SXC/XC-W/XCR-W (4-Strokes)
  • Hot  28 replies
 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.