Hard starting 650L

4 replies to this topic
  • traildog1

Posted September 16, 2007 - 11:38 AM


I have a 93 650L that has been hard starting. Seemed to be worse when cold. Some investigation revealed that there is no spark while cranking. It wil spark when the starter button is first pressed and again as it is let go but not while cranking. What's up with that? Any ideas?

  • XR650L_Dave

Posted September 17, 2007 - 08:30 AM


1st, take both wires that go to the clutch lever switch and ground them both- this will bypass all crank&run safeties.


Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • martinfan30

Posted September 17, 2007 - 08:37 AM


if that isnt it, check the stator and cdi unit.

  • traildog1

Posted September 20, 2007 - 04:28 PM


Thanks for the suggestions guys. Turns out a tight exh valve was the culprit for the hard starting. I'm still baffled about the spark think though. Could that be a built in thing so you can't overrun the starter by blipping the throttle while it's cranking? Just a thought but it sounds good.

  • martinfan30

Posted September 21, 2007 - 07:38 AM


try the safety bypass.

Related Content


Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.