Jardine muffler

4 replies to this topic
  • hotdog7

Posted September 06, 2007 - 08:25 AM


I have a 2002 wr426 just put on a new jardine rt4 slip on muffler on it and when we got back from rideing I was washing the bike when I noticed that the muffler has tire marks on it my tire is kenda 778 dot 120-90-18 anyone else have this problem? also think I may have lost some top end speed.:thumbsup:

  • GCannon

Posted September 06, 2007 - 08:52 AM


I got a new FMF Q2 and I love it! its quiet with good low end power . the low end power may have improved over my extremely loud YZ pipe.

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • hotdog7

Posted September 06, 2007 - 09:00 AM


Yea I would have liked to get another muffler but I got this one on ebay for $109.00 and for that price could not pass on it I will need to get a spark arrester this is new muffler.also my tire is getting chewed by the chain

  • 02WR426Cali

Posted September 06, 2007 - 03:28 PM


Get rid of the kenda they suck! I had a millville 778 I believe is the number. It started to chunk on the first ride and was pretty much destroyed after two rides. I was riding in rocky condtitions, but my dunlop 756 held up for almost one year in the same conditions.

  • jpfire

Posted September 07, 2007 - 08:12 AM


Just curious, did you have to re-jet after putting on the Jardine? Ciao JP


Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.