Battery life

10 replies to this topic
  • johnnyjeep

Posted September 05, 2007 - 04:19 AM


I am starting to have some electrical problems. It is looking like a battery problem. I was just wondering how long the stock battery has lasted for other WR owners. Mine is about 16 months old.

John in Vegas

  • trailordune

Posted September 05, 2007 - 08:04 AM


Be more specific about the problem. I've got the original battery in my 04. I had replaced it after about 1 year thinking it was bad due to a headlight short. Now it's back in the bike after sitting in the garage dead for 2 years and it works perfect.

  • jim-in-so-ore

Posted September 05, 2007 - 09:40 AM


I still have the original battery in my 6100 mile 2003 WR 450. It cranks a little slow and I'm just now thinking of replacing it, but it is still working.:thumbsup:

  • kskyles

Posted September 05, 2007 - 12:11 PM


mine was 2 years old when it finally went bad....but the phoenix heat kills any batteries in your garage.

  • dustinw

Posted September 05, 2007 - 01:06 PM


The absolute worst thing you can do to a lead acid battery and the thing that kills them the fastest is letting them go stone cold dead. If you give the battery a work out every other week or so, they will last a long time. I had a battery in my 2002 VFR that lasted almost 4 years until I let it go dead over a summer, then it was just toast after that.

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • rich1167

Posted September 05, 2007 - 02:32 PM


My stock batt was dead when I bought the bike. It was only 6 months old. The guy that owned it let it die and the batt was done for. Best thing to do is keep it on a tender. Most tenders come with a cable that can hard wired and ran out from under the seat. Mine is always pluged in when in the garage.

  • johnnyjeep

Posted September 05, 2007 - 04:02 PM


Ok, to be more specific, it started to crank real slow, then the headlight went out, now it wont crank at all, but it still powers up the puter, but resets the odometer. I can kick start it, and the battery doesnt charge at all. To be fair, I havent looked at anything, including the light, yet. The bike doesnt sit much, goes out 2-3 times a week. I was just trying to get an idea about the battery life. Thanks.

John in Vegas

  • BEAN329

Posted September 05, 2007 - 10:04 PM


Mine is stock 2003 wr450

  • new2blu

Posted September 06, 2007 - 05:41 PM


Still have my original battery on my 03 WR450 with no problems (always on a battery tender when in the garage).

  • bicyclebob

Posted September 06, 2007 - 08:40 PM


Pull off the seat and check the voltage on the battery terminals with the bike running. It should be around 14 vdc. The ignition and charging circuits are completely seperate in the stator so your bike will run with a dead battery but the lights won't work and you will have no electric start. If you have a low reading at the battery go through the regulator test procedure in the service manual. Hope this helps.

  • johnnyjeep

Posted September 08, 2007 - 12:46 PM


Ok, here is the poop. Put a BD kit on it when it was new. Something went wrong with the electrical, so a friend rewired the stator back to stock. After 14 months, his solder job fell apart. Got that resoldered and the bike and battery are working fine.

Thanks again guys.

John in Vegas


Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.