WR450 Stalling Problem


9 replies to this topic
  • fun4evr

Posted August 27, 2007 - 07:50 AM

#1

I have an '05 WR450 that stalls when it gets hot. Just had the bike tuned-up, valves adjusted, the works, and it still stalls. It will start when it cools down for 10-15 min, but will stall again when it gets hot! Any suggestions?

  • ETP

Posted August 27, 2007 - 08:06 AM

#2

Welcome to TT. Can you give us more info? Does it stall while riding or just sitting idle. Is there any evidence of coolant overheating? Does it sputter, then die. Stuff like that.

  • phatcat99

Posted August 28, 2007 - 06:38 AM

#3

I've got a buddy who's riding an 04 YZ250F and had the same problem. Shop traced it to worn out carb. seals. An air leak formed and was causing it to stall once the engine was warm. Just a thought.

  • face_plant

Posted August 28, 2007 - 10:44 AM

#4

mine stalls after a extremely hard motard run through town :p
but its only when i am idling

  • DB_Cooper

Posted August 28, 2007 - 01:47 PM

#5

YOUR "HOT AND STALL" SOUNDS LIKE A ELECTRICAL PROBLEM.:cry: I WOULD CHECK THE STATOR AND PULSAR OHMS READINGS WHEN COOL AND THEN CHECK THEM WHEN THEY ARE HOT AND BIKE "STALLS". IF THEY STAY WITHIN SPECS, THAN MORE THAN LIKELY A CDI UNIT HAS GONE SOUTH. UNLIKE THE DRZ/KTM'S THE YAMAHA USUALLY HAS A VERY SOLID ELECTRICAL SYSTEM. PLEASE KEEP US ADVISED AS TO WHAT YOU DISCOVER...

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • fun4evr

Posted September 19, 2007 - 06:56 AM

#6

I have an '05 WR450 that stalls when it gets hot. Just had the bike tuned-up, valves adjusted, the works, and it still stalls. It will start when it cools down for 10-15 min, but will stall again when it gets hot! Any suggestions?

It mainly dies while riding, and the way it stalls is like it runs out of gas. I took the carb out (what a pain that was) and am currently in the process of cleaning it. I will keep you all informed if this was or was not the problem.

  • dazzabb

Posted September 19, 2007 - 08:54 AM

#7

Does the engine start to "race" just before stalling, if so thats pointing to an air leak.

Fact that it "behaves like its running out of gas" suggests its lean, likely caused by an air leak.

  • fun4evr

Posted October 17, 2007 - 08:43 AM

#8

It was the carb. It just needed to be cleaned. Once it was cleaned, it now runs as good as new! Thanks for the advice!!!

  • yz-dwg

Posted October 17, 2007 - 07:01 PM

#9

It was the carb. It just needed to be cleaned. Once it was cleaned, it now runs as good as new! Thanks for the advice!!!


Do these need to be cleaned often? Ive been riding mine every weekend for the last year and I assumed running fresh gas thru it regularly would keep it clean, what do you guys think? should I clean my carb for GP?

  • steve10391

Posted October 17, 2007 - 07:39 PM

#10

If it aint broke dont fix it.




 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.