XR650L oil pressure problems!


6 replies to this topic
  • stepho

Posted August 19, 2007 - 03:33 PM

#1

Hi everyone. First timer here. I have a 2003 XR650L that I just resealed the cyl head and base gasket and i am having an issue with getting oil to move from the oil pump to the filter and cyl head. Oil pump looks good put new o rings on it did not get the oil lines swapped. It does return oil to the frame but no oil comes out the hole going into the oil filter housing. HELP IF YOU CAN MAN. thanks

  • martinfan30

Posted August 19, 2007 - 07:05 PM

#2

it does take a while to get oil moving in these engines if they have been O/H..

  • stepho

Posted August 19, 2007 - 07:48 PM

#3

oil is filling up oil tank but not oil filter housing. I checked and cleaned the strainer not sure what is up. driving me crazy:crazy:

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • martinfan30

Posted August 19, 2007 - 08:25 PM

#4

sounds like you have a restriction somewhere. check your flex lines at the bottom of the down tube, may be twisted/kinked.

  • XR650L_Dave

Posted August 20, 2007 - 07:48 AM

#5

Also, if you drained the oil from the pump, you must prime the pump.

Dave

  • stepho

Posted August 20, 2007 - 09:14 AM

#6

What would be the best way to prime the pump. over fill? A little air pressure, sit over night?

  • martinfan30

Posted August 20, 2007 - 09:17 AM

#7

http://www.thumperta...me the oil pump

this thread should be helpful.





Related Content

 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.