mounting trials tires

6 replies to this topic
  • waterdirt

Posted July 14, 2007 - 05:21 AM


hey guys, great site! well i just bought a dunlop 803 trials tire for my 07 wr 450. i have the tire mounted but i am having trouble setting the bead. pointers?

  • face_plant

Posted July 14, 2007 - 07:36 AM


soap and water inflate the tire 3-4 times without the valve stem in
on the 4th time put about 60 psi and let the soap and water work in should hear a nice pop

if not take it to a shop might charge you 10$

  • Just_a_trail_rider

Posted July 14, 2007 - 09:06 AM


I agree. soap and water. break out the compressor and got to 70lbs. That will do it.

I ran my trials tire at 12psi. Still gripped like velcro and didn't break the bead.

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • waterdirt

Posted July 15, 2007 - 03:55 AM



  • Tough Guy

Posted July 15, 2007 - 11:28 AM


I used soap and water as well, make sure the bead is not hanging up on the bead lock(s)....I keep mine (Michelin X-11) at 9-10psi and love it! I have 400 miles on it and it still looks great and I haven't had a lick of trouble.


  • gregwr450f

Posted July 15, 2007 - 11:47 PM


60psi and leave overnight.

  • waterdirt

Posted July 16, 2007 - 02:34 AM


i have never had to put 70lbs in a tire to set the bead, but it worked ,somewhat scary!


Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.