BK Mod done (no squirt!)



7 replies to this topic
  • Mike_D.

Posted February 21, 2002 - 01:36 PM

#1

I got through all the steps of the BK Mod (which
was a snap thanks to posts from fellow TT'ers).

So now I'm ready for the fun part (adjusting
duration/timing of the fuel "squirts"); I
filled my tank with gas, connected the fuel
line, switched the petcock to "on" and waited a few minutes for the bowl to fill, then while
holding the carb upright and to the side of the bike, I manually turned the throttle cable wheel over and over waiting for the gas... dry as a bone.

Am I missing a simple step here?

[ February 21, 2002: Message edited by: Mike D. ]

  • Tim_in_WA

Posted February 21, 2002 - 02:09 PM

#2

Make sure the squirt duration screw (the one you drilled and tapped)is backed off so that it is not touching the accel. pump arm. When you twist the throttle, you should be able to see the black accel. pump arm move toward the screw. You should be getting a squirt as the arm moves.

If still no success, you might have to disassemble and clean the accelerator pump assembly, and maybe even the entire carb.

  • SealClubber

Posted February 21, 2002 - 02:33 PM

#3

Mine did the same thing. It didn't start to work until after I put the carb back on the bike with everything hooked up. Why? I have NO idea! :)

  • Mike_D.

Posted February 21, 2002 - 07:34 PM

#4

[ February 21, 2002: Message edited by: Mike D. ]

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • Mike_D.

Posted February 21, 2002 - 07:39 PM

#5

[

[ February 21, 2002: Message edited by: Mike D. ]

  • Mike_D.

Posted February 21, 2002 - 07:42 PM

#6

[ February 21, 2002: Message edited by: Mike D. ]

  • Mike_D.

Posted February 21, 2002 - 08:12 PM

#7

Thanks Tim:

I thought I had checked for clearance of the
newly installed adjustment screw and the accel
pump arm, but I re-checked after reading your
post and it was barely clear and still impeding
movement.

I backed the screw off more and now I'm squirting
gas all over the garage at 1:15 AM!!!

Thanks alot for your reply, I really appreciate
the help!!!

  • Tim_in_WA

Posted February 21, 2002 - 10:03 PM

#8

Glad you got it working Mike. Also, make sure that after you set both of the adjustment screws (squirt timing first, then duration), go back and re-check them. I discovered that adjusting one of the screws affects the other's setting. Try to get them as close as possible before reinstalling the carb.

Then take a screwdriver with you when you take it out for the first test ride, because you'll likely have to do some more fine adjusting on the screws. I had to make about 10 to 15 small adjustments between the two screws before I found the "sweet spot"! And man is it sweet!!! :)




 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.