Pig died on the trail....HELP!


5 replies to this topic
  • bobscoffeeshop

Posted July 06, 2007 - 03:37 PM

#1

I was just riding along today when the BRP just decided to die. Nothing seized, or smoked, or clanked, or banged, or boiled....it just sounded like it was getting tough to get fuel to the engine, then sputtered to a stop.

Anyone have any "top of mind" ideas of what might have happened?

I was able to bump start it, then it ran for a moment, then it just didn't want to run, so I shut it down. It wouldn't idle.

Thanks.

  • calgaryfiddy

Posted July 06, 2007 - 03:43 PM

#2

I had the same problem but on a city road... it just died coming up to an intersection when i pulled in the clutch.

I ended up having to crank up the throttle stop (idle thumbscrew) to finally get it to run but REASON i had to do that was because the linkage between the throttle valve/slide and the twist assembly loosened off.

Take the top of the carb off, and stick a screwdriver down into the valve and see if the screws are loose. Mine must have been loose and caused the initial problem because once i did finally take the carb top off one screw was completely unscrewed and bouncing around the valve.

Also check out my previous thread...
http://www.thumperta...ad.php?t=523009

Its quite thorough i think. If after checking spark and fuel to the carb then i'd bump the idle screw up.

  • martinfan30

Posted July 06, 2007 - 10:28 PM

#3

is this an L or R ? if its an L, start thinking about a cdi!

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • Dual_Dog

Posted July 07, 2007 - 06:10 AM

#4

I was just riding along today when the BRP just decided to die. Nothing seized, or smoked, or clanked, or banged, or boiled....it just sounded like it was getting tough to get fuel to the engine, then sputtered to a stop.

Anyone have any "top of mind" ideas of what might have happened?

I was able to bump start it, then it ran for a moment, then it just didn't want to run, so I shut it down. It wouldn't idle.

Thanks.

Check the fuel tank vent hose (if it has one) to see if it's clogged or pinched off.

  • ttmojo1

Posted July 07, 2007 - 04:20 PM

#5

Check the fuel tank vent hose (if it has one) to see if it's clogged or pinched off.


I had an aftermarket vent hose with ball float internal end , it just
stopped letting air in as the tank went down and eventually caused
enuff vaccum to stop gas goin into carb. When I took the gascap off
I could hear air rushing in. Thats how I figured it out.

Tony

  • bobscoffeeshop

Posted July 07, 2007 - 09:52 PM

#6

Thanks for the replies...

As it turns out... it looks like it was a vacuum problem with the tank cap....and a bad plug.





Related Content

Forums
Photo

Engine Loping/Sputtering by tcaldwell


Dirt Bike   Make / Model Specific   Honda   XR600/650
  • 2 replies
Forums
Photo

2015 XR650L Squeaking noise by Crayjay


Dirt Bike   Make / Model Specific   Honda   XR600/650
  • 3 replies
Reviews

Honda XR650L 2016 by Chris.GVS


Honda XR650L 2016
  • - - - - -
  • 0 reviews
Wiki
Want to add a kickstart to your XR650L?  Here's how - last post by clc3251

Want to add a kickstart to your XR650L? Here's how


Articles
  • 1 reply
Forums
Photo

Post Apocalypse, ThumperTalk style! by Justin Pearson


Dirt Bike   General Dirt Bike Forums   General Dirt Bike Discussion
  • Hot  35 replies
 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.