Edelbrock Issues - Weird Low Idle


4 replies to this topic
  • DualSport650

Posted July 05, 2007 - 04:32 PM

#1

Hey Guys,

I'm having an issue with my Edelbrock Carburetor and need some advice.

First of all, I LOVE this carb. It's performs great. :thumbsup:

I installed it about 2 years ago and it ROCKS -- except for 1 issue.

Here's the problem...

When I let off the throttle when I'm coming to a stop or coming into a corner it idles REALLY REALLY LOW.

So low that if I grab the throttle, my bike stalls. Or even if I don't grab the throttle, it just idles too low and dies. It drives me NUTS!!!

When I turn up the idle adjuster knob it still idles too low about 75% of the time. The other 25% it idles way to high. :busted:

Everything looks OK. The cables seen to be free of slack or stickyness, etc.

Yet, I have low idle issues.

&%$#@!?

Anybody know how to fix this??? :thumbsup:

  • creeky

Posted July 06, 2007 - 05:12 AM

#2

I have had problems with inconsistent idle with two older non-pumper Edelbrocks, the slides were hanging up and and would stop at different positions when the throttle was chopped. Sometimes the idle would be too fast, sometimes too slow causing stalling. Both problems were cured with improved design slides from Edelbrock. Don't know if this is you problem, but might be worth considering.

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • Agent2

Posted July 06, 2007 - 08:07 AM

#3

Maybe a little too rich? Sounds like what my bike does sometimes when I do a big change in elevation, runs great, but when I come to a stop it sounds like it's going to die, give it a little throttle and it does. Try 2 clicks to the left on the red knob.

  • DualSport650

Posted July 06, 2007 - 12:55 PM

#4

Maybe a little too rich? Sounds like what my bike does sometimes when I do a big change in elevation, runs great, but when I come to a stop it sounds like it's going to die, give it a little throttle and it does. Try 2 clicks to the left on the red knob.


Thanks for the advice Creeky and Agent2.

I'll try the easy tweak of leaning it out a little - 2 clicks to left.

It is sucking gas a little more than I feel is normal.

Ride on! :thumbsup:

  • Agent2

Posted July 07, 2007 - 06:27 AM

#5

DualSport650 - one other thing it "might" be, the needle valve going into the float bowl tends to gum up causing it to stick. Once a year I take the pumper apart and give it a good cleaning. It's a long shot, but another possibility, let us know what you find out.





Related Content

 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.