2007 yz450f rekluse anyone got it?


16 replies to this topic
  • Yamaha4lyfe

Posted July 01, 2007 - 02:15 PM

#1

k well i have had my bike for a while along with the clutch i have it setup weard to get it to work half decent
this is how i have it setup to get a tight .30 fit
rekluse upper assembly
friction disk
rekluse drive plate
rekluse drive plate
stock drive plate
friction disk
rekluse drive plate
rekluse drive plate
friction disk
stock drive plate
friction disk
stock drive plate
friction disk
stock drive plate
friction disk
stock drive plate
friction disk

ok anyone have a 2007 yz4550f that is actually setup correct not like that.
it still works but it doeset work well in very tall gear at low rmp it stalls
say im coming into a corner fast that is Gnarly with roots i don't have time to gear down i hit throttle and it kicks a bit sometimes it stalls. but rarely the bike is jetted perfect for my elevation and is tested on a EGA would it be a carb problem maybe needs a accel pump cova? or am i handicap and cant find a way to properly adjust my clutch.

also the manual says the rekluse drive plates are .55 i measured them with a digital caliper it says they are .39 :thumbsup: they are smaller then the stock ones how does that work????:thumbsup:
i have emailed rekluse a lot still haven't gotten a usable answer

thanks to anyone who replys

  • dforbes67

Posted July 03, 2007 - 03:02 AM

#2

call 1-208-426-0659 always got a real person that helped any time , had a rekluse in my 426 and bought parts to put it in my new 07 450 ,works great .I think the stock plates are .65 and you use 5 .055 plates from rekluse all staggard ,plate , friction, plate , friction ,with nothing doubled up .
Also if you are trying to take off in a hurry it will stall ,you still have to be in the right gear .mine has the moto cross spring and did a lot better with stalls than the woods spring or light spring I had on the 426.

  • bowvan

Posted July 03, 2007 - 01:20 PM

#3

I've had the rekluse in my 07 for 5 months now, with no problems. I installed it exactly how the instuctions said and it works great... no stalling! Make sure you are measuring the correct gap. It easy to mistake the gap between the two steel plates as the gap you need to measure. You want to measure the gap between the first steel plate and the first fiber plate. This requires that you force the tool between the first two steel plates and into the fiber plate. Your bike is so new, that you probably don't have much clutch wear. You might not even be able to get the tool in between the first steel plate and the first fiber plate, I couldn't. I would re-install per the instructions and ride it. Don't worry about the gap (assuming you haven't hammered your clutch).

Also, make sure you adjust the lever per the instructions. You will probably have to loosen almost all of your adjustment to get the proper "freeplay"

If your clutch does slip, then install the provided spacer plate.

  • Yamaha4lyfe

Posted July 03, 2007 - 07:10 PM

#4

bovan, my clutch setup would not fit when i did it using all 8 friction plates. and following the exact instructions

i have setup a rekluse before on my 06 rm250
i have put alot of ware on it by now. i never got a spacer plate with my package hmm

  • bowvan

Posted July 03, 2007 - 09:51 PM

#5

My kit came with an extra steel spacer (plate) that they said to use if your measured gap was too large. The kit also included a thicker gasket for the clutch cover, to allow for the larger basket.

Sounds like they might have given you the wrong kit?

  • bowvan

Posted July 03, 2007 - 09:54 PM

#6

By the way, I have the pro model installed in my 07 yz450f.

  • ker-b

Posted July 06, 2007 - 08:24 AM

#7

Have to agree with bowvan, I have the pro also and it went in perfectly according to instructions and works better than i could have imagined.
I will say i had idle speed too low at first and encountered some stalls but since i bumped that up a bit it rarely stalls and if it does its because of me...
and yes it was friction, plate, friction, plate staggared and no doubling up.

  • 12yamaha

Posted July 18, 2007 - 09:50 PM

#8

What kind of oil do you use with the rekluse. My kit is on the way to go in my 06 YZ450 and just wondered if I can still use Amsoil?

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • Yamaha4lyfe

Posted July 19, 2007 - 12:00 PM

#9

right now im using bell ray thumper ordered it from my dealer and its only semi synthetic. stupid bike shop

im thinking on running alot thicker oil is that a problem with my engine? maybe a stright full synthetic 80w?

  • grayracer513

Posted July 19, 2007 - 01:55 PM

#10

Why on earth would you do that?

  • LVThumper

Posted July 19, 2007 - 03:14 PM

#11

Why not use the Shell Rotella T as recommended by Rekluse? I have been using it for over a year, and although Grey and others will say it wears down too fast, at $8.00 a GALLON :applause: from WalMart, you can afford to change it every ride! :ride: I would agree that it is not the best oil for EXTENDED use, but if you keep it fresh (I do mine about every 80 - 100 miles) you shouldn't have any trouble at all. my $.02 :thumbsup:

  • 12yamaha

Posted July 19, 2007 - 09:54 PM

#12

I really like synthetic oils. If it won't hurt the clutches I am gonna go back that route if gray says it is ok. Synthetic oils don't break down like regular oils and here in Tennessee during the summer it gets real hot in the woods.
So what do you think gray? Synthetic or not?

  • Yamaha4lyfe

Posted July 19, 2007 - 10:27 PM

#13

well whats it worth to you? a shitty grade oil and a little less clutch ware and alot more engine ware?

or full synthetic oil with little engine ware and a little more clutch slippage. (not ware) ??? hm think about it bud :p

  • Yamaha4lyfe

Posted July 19, 2007 - 10:28 PM

#14

Why on earth would you do that?


just a question. why not? oil pump have to much trouble pushing it though my engine?

  • grayracer513

Posted July 20, 2007 - 07:46 AM

#15

well whats it worth to you? a shitty grade oil and a little less clutch ware and alot more engine ware?

or full synthetic oil with little engine ware and a little more clutch slippage. (not ware) ??? hm think about it bud :p

For the 1464th time, synthetic oils will not make your clutch slip.

http://www.thumperta...808#post5007808

  • grayracer513

Posted July 20, 2007 - 07:54 AM

#16

just a question. why not (run 80w)? oil pump have to much trouble pushing it though my engine?

Running too heavy an oil will reduce lubrication, not improve it. Volume of oil delivered is more important than viscosity, especially for "plain bearing" items like the camshafts. Using thicker oils slows the flow through the system, and if it's thick enough, it may only rarely get to items like the main bearings that rely on oil draining or splashing onto them. And, the extra load placed on the pump is both a wear factor for the pump drive, and a parasitic loss.

Using a good grade of oil, 40wt is all you would ever need until the outside temperature goes over 105-110 (F). Using heavier oil won't make anything better.

  • CaptainKnobby

Posted July 20, 2007 - 12:44 PM

#17

I've been useing Amsoil MCF 10w-40w for a month now in my 06 and it is working great.





Related Content

 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.