Help Please...XR650R Stalled, now wont start

24 replies to this topic
  • Old_Man_Time

Posted June 25, 2007 - 08:33 PM


You have the hanging idle fixed now but quite often it is the result of the throttle cables being routed underneath the tank mount instead of over the top of the mount. When this is done the idle would also increase when you turned to the right.

In your case it was other cable issues and am glad to hear you got it resolved.

  • calgaryfiddy

Posted June 25, 2007 - 09:09 PM


The hanging idle is still there...i adjusted the pilot screw by the MAC multimeter has a nifty tachometer and inductive pickup with it.

We were playing with the throttle valve last night and even when you forcible turn the throttle off the idle would hang. We removed the top cover and tried to hold the throttle valve up but when turning the throttle off it would shut every time.

I will adjust the cables tomorrow though...the most experienced rider wasnt at work we'll mess with it tomorrow.

Oh since adjusting the pilot screw it RIPS now...i pulled out of the driveway accelerated hard and the front end lifted by accident...i can't wait to ride it tomorrow.

I also installed new brighter signal lights, and painted the side covers black...they look terible !! I'm too impatient to paint...and i end up with thick coats. Oh well, let it cure and scuff it an do a think coat tomorrow night.

Thin coat the next night...etc...

Thanks for all your help guys...i'll let you know what it ends up being.

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • Old_Man_Time

Posted June 26, 2007 - 06:40 AM


Having reread this thread I noticed you don't say anything about if this bike has been uncorked or not. Does the bike have the power up kit installed or is it still plugged up?

When it comes to the hanging idle I have a question for you. Did the bike idle really slowly when you first bought it? It seems like it must have since turning up the idle screw was one of the things that made it start.

It has been so long since I ran a stock carb that I forgot about this point. If the idle is set too high on the stock carb the idle will hang when let off the throttle after snapping it. Provided you do not have a lean condition which is not likely if the bike ran fine when you bought it. Then you have the idle set too high. Just turn the idle screw down a little at a time reving the bike after each adjustment until you get rid of the hanging idle. I know it sounds too simple but try it.

If your pilot jet is too small this won't work.

Also check this link out and the picture to see that you have routed your cable correctly.

  • calgaryfiddy

Posted June 26, 2007 - 08:11 PM


Ok i think i got everything settle and came up with a theory based on a big surprise when i pulled the top cover off the bike.

After i got the top cap off and looked into the throttle of the screws for the link arm, which also holds the needle in place... was completey out of its threads and bouncing around inside the throttle valve.

So heres my theory. The other screw was loose as well, so it was jetted by the previous owner, rode it no problems, when i had my first stall in the parking lot the screw had worked itself loose enough to cause the idle to drop for some reason. Then by the time i rode down the street and it stalled for good it had backed out and was quite loose.

I dont see how it would affect the idle, its not like a loose screw inside the carb would cause a vacuum leak would it, or the needle was loose and off kilter so it was seating in the needle jet properly.

Anyways the hanging rpm was from the sporadic path of the throttle valve as it chattered its way down. I took the valve out and cleaned it and the bore up really well anyways. And when i started it after having it all idle was at arund 4000 !! I had it set at 1400 with a digital tach yesterday. What a least its figured out though.

So now...i have to re-tune the pilot jet tomorrow, not a big deal though, i'm grinning from ear to ear after having it all figure out.

  • Old_Man_Time

Posted June 27, 2007 - 09:06 AM


That sure was a unusual one. Never would have guessed it. Good thing you took the top off the carb or you would have been doing all kinds of useless fixes getting no where. Way to go :thumbsup: :thumbsup:

Related Content


Post Apocalypse, ThumperTalk style! by Justin Pearson

Dirt Bike   General Dirt Bike Forums   General Dirt Bike Discussion
  • Hot  35 replies

What was your path to Beta? by officialhopsof

Dirt Bike   Make / Model Specific   Beta
  • Hot  79 replies

Wiseco 101MM Spark Knock Low Engine Temps by imandrewparks

Dirt Bike   Make / Model Specific   Honda   XR600/650
  • 7 replies

Which thumper motor for a street tracker? by woz

Dirt Bike   General Dirt Bike Forums   General Dirt Bike Discussion
  • * * * * -
  • Hot  29 replies

2015 XR650L Squeaking noise by Crayjay

Dirt Bike   Make / Model Specific   Honda   XR600/650
  • 3 replies

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.