misterious broken throtle valve slide 99 wr helppp



3 replies to this topic
  • enrique_prieto

Posted February 16, 2000 - 05:49 PM

#1

hello everyone on sunday at 10 am i was climbing a mountain at full throttle and when i got to the top misteriously the bike stopped and didnt start , when i hited the kikstart it fel like something was scraping the cilinder i removed the cams and the train valve to chek the valves found 3 pieces of metal in the top of the piston.and came from the throttle valve slide of my keihin carb so im a little woried why did it broke?
Do i have to buy a new carb or they sell the part and who sells it please help.

  • sbohanon

Posted February 17, 2000 - 03:09 AM

#2

from reading a few other post and technical articles at this site it sounds normal. i would like to know if this has happened to any '99 yz400s'

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • Mech

Posted February 17, 2000 - 08:13 AM

#3

Hey there,
This is a common problem among WR/YZ. Just order a new slide from your dealer maybe BAJA or yamaha, but bewarn the slide cost $200 the last time BAJA gave me a quote. F*# KING expensive. Besure that you remove all the derbis from your block and use a air JET to blow all the metal pieces out. Just disassamble the carb and reinstall the slide. To advoid this situation Check your carb slide for any crack and clean your carb componets regularly. :)

  • nahbeh

Posted February 17, 2000 - 07:20 PM

#4

I can't understand why it cost $200 over there. Here in Singapore, it cost just US$90.




 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.