why does my crankcase vent leak oil?


12 replies to this topic
  • rodeoripper75

Posted June 17, 2007 - 02:18 PM

#1

i have an 07 wr 450f and i took off all the smog parts and vented the crankcase because when i first removed the smog specs i plugged the whole and it blew out my valve cover seals. now i have vented it only like about a foot and a half worth of hose and it worked cause i put a little filter on top but it clogged up and blew oil everywhere. now i ran a longer hose and vented it with some lightweight foam like as if it were from a pair of goggles about that thin. so then i ran it up and down the street a few times and then it blew out more oil i have no idea why its doing this if anyone can help me for a solution that would be great thanks.

  • SXP

Posted June 17, 2007 - 04:24 PM

#2

i have an 07 wr 450f and i took off all the smog parts and vented the crankcase because when i first removed the smog specs i plugged the whole and it blew out my valve cover seals. now i have vented it only like about a foot and a half worth of hose and it worked cause i put a little filter on top but it clogged up and blew oil everywhere. now i ran a longer hose and vented it with some lightweight foam like as if it were from a pair of goggles about that thin. so then i ran it up and down the street a few times and then it blew out more oil i have no idea why its doing this if anyone can help me for a solution that would be great thanks.


Here's a solution for you: put the fricking thing back the way it was:foul: This is a good example of getting too smart for your own good. What's wrong with the design the way it is, anyway? Why are you dicking with the vent hoses? Removing the smog crap is one thing, but why, oh why, are you messing with the vent hose plumbing?

  • dl19

Posted June 17, 2007 - 04:39 PM

#3

Wow...you upset the last one...I re-routed my 05 to keep it out of the water, but it has minimal if any blow by. Not even enough to run inside the carb boot. If the 07 is routed in a good location don't mess with it, but you can always run it into your air box. I would run it so anything it blows out will be filtered. Just get a plastic hose fitting. Search the 03 model as it was popular on that model.

  • rodeoripper75

Posted June 17, 2007 - 05:25 PM

#4

thanks but im not sure if you understand cause many people told me that that was an ok thing to do and i was showed how to do it and i did it right but i dont understand why all of a sudden after 2 months it just shot out oil im not saying your wrong im just looking on some advice on how to fix it hopefully i may get some more advice on this subject and it'll be more clear so i dont have to put it all back together thanks for all your help.

  • SXP

Posted June 17, 2007 - 06:25 PM

#5

Wow...you upset the last one...I re-routed my 05 to keep it out of the water, but it has minimal if any blow by. Not even enough to run inside the carb boot. If the 07 is routed in a good location don't mess with it, but you can always run it into your air box. I would run it so anything it blows out will be filtered. Just get a plastic hose fitting. Search the 03 model as it was popular on that model.



dl19 - The 07 has a completely "sealed" crankcase breather system. The hoses either purge back into the engine or the air box. There's nothing dangling below the frame to suck water up by, so I don't understand why you would want to "vent" it. I'm not sure if the 05 is the same, but the 07 seems like a great design to me.

  • SXP

Posted June 17, 2007 - 06:27 PM

#6

thanks but im not sure if you understand cause many people told me that that was an ok thing to do and i was showed how to do it and i did it right but i dont understand why all of a sudden after 2 months it just shot out oil im not saying your wrong im just looking on some advice on how to fix it hopefully i may get some more advice on this subject and it'll be more clear so i dont have to put it all back together thanks for all your help.


rodeoripper75 - Sorry for the irate reply - bad day:thumbsdn:

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • dl19

Posted June 17, 2007 - 09:22 PM

#7

sxp...the 07 sounds like it is the same as the 05. Just raises the location in the air box from the bottom to the top. Nothing major just a preference.

  • rodeoripper75

Posted June 25, 2007 - 06:28 PM

#8

ok if your looking at the left side of your engine, you got the crankcase, and then theres a little vent or something to the slight upper right. im slighty mechanically able but the thing is i work on my trucks and know stuff by learning it myself i was shown how to do the venting and it was right. back to my subject the vent thing...(sorry dont know the name) had no plug and it was ran up to the smog but when i removed the smog pump i had a big open vent and that is why i first seeked help and was told to plug it by 3 different dealers that it was ok... it blew my valve cover gasket. so i replaced it and routed it upwards to breathe without leaking everywhere. i just did an oil change and let my brother ride it and then he came back and said its leaking oil eveywhere and it was. so now im at the point of not able to figure it out and ive asked and asked and asked and now that is why i have come to the experts. thanks everyone hopefully this may make little more sense of what im trying to say cause i barely know what im saying cause i dont know part names but if you do get it help me please thanks.

  • ccoates445

Posted June 25, 2007 - 06:45 PM

#9

ripper, pm me and i'll give you my # and talk you thru it.

  • SXP

Posted June 25, 2007 - 06:46 PM

#10

ok if your looking at the left side of your engine, you got the crankcase, and then theres a little vent or something to the slight upper right. im slighty mechanically able but the thing is i work on my trucks and know stuff by learning it myself i was shown how to do the venting and it was right. back to my subject the vent thing...(sorry dont know the name) had no plug and it was ran up to the smog but when i removed the smog pump i had a big open vent and that is why i first seeked help and was told to plug it by 3 different dealers that it was ok... it blew my valve cover gasket. so i replaced it and routed it upwards to breathe without leaking everywhere. i just did an oil change and let my brother ride it and then he came back and said its leaking oil eveywhere and it was. so now im at the point of not able to figure it out and ive asked and asked and asked and now that is why i have come to the experts. thanks everyone hopefully this may make little more sense of what im trying to say cause i barely know what im saying cause i dont know part names but if you do get it help me please thanks.


Where do you live? If you are in Socal bring your bike over and we'll sort it out.

  • SXP

Posted June 25, 2007 - 06:51 PM

#11

ok if your looking at the left side of your engine, you got the crankcase, and then theres a little vent or something to the slight upper right. im slighty mechanically able but the thing is i work on my trucks and know stuff by learning it myself i was shown how to do the venting and it was right. back to my subject the vent thing...(sorry dont know the name) had no plug and it was ran up to the smog but when i removed the smog pump i had a big open vent and that is why i first seeked help and was told to plug it by 3 different dealers that it was ok... it blew my valve cover gasket. so i replaced it and routed it upwards to breathe without leaking everywhere. i just did an oil change and let my brother ride it and then he came back and said its leaking oil eveywhere and it was. so now im at the point of not able to figure it out and ive asked and asked and asked and now that is why i have come to the experts. thanks everyone hopefully this may make little more sense of what im trying to say cause i barely know what im saying cause i dont know part names but if you do get it help me please thanks.


Did you buy the smog block-off kit? It has a plate that covers the hole left by the metal steel "U" tube that you removed. Is this the hole you are referring to?

BTW, gets this sorted out before you ride the bike. It would be a shame to screw up your new bike.

  • rodeoripper75

Posted June 25, 2007 - 08:43 PM

#12

whats up i just got your message my # is (707) 591 1481

  • rodeoripper75

Posted June 25, 2007 - 08:45 PM

#13

sorry im no where near you but i do live in the bay if like up by richmond




 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.