Stator testing results and a question


3 replies to this topic
  • cjcosmos

Posted June 01, 2007 - 08:34 PM

#1

Hello all,

So I have been trying to diagnose the electricals on the XL. I followed the instructions in my manual for testing the stator and found that the lighting coil had .8 ohms resistence and the charging coil .4 ohms, which fall close to acceptable limits within ~.1 ohms. I am still concerned because I get no power at the headlight plug and only 2.3 volts at the battery (4.5 when revved).

Does this still mean my battery is dead? My manual did not cover how to test the AC module(?). Is this something that I need to test and how do I go about it?

Thanks and take care!

Chris

  • DOHCFOX

Posted June 11, 2007 - 06:51 AM

#2

Hey guys,

Chris and I went through the electrical system last night and threw a new battery in. It seems that we need to contact Ricky Stator and order a new stator. I wanted to run this by you all once more before forking over $130 for a new unit.

Thoughts?

JT

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • martinfan30

Posted June 11, 2007 - 07:12 AM

#3

even though the resistance is good, doesnt always mean the part is good.

  • DOHCFOX

Posted June 11, 2007 - 09:30 AM

#4

That's what I figured. Sounds like we'll be ordering a new stator!

JT





Related Content

 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.