01 YZ426 Cluch Problem


5 replies to this topic
  • fbroll

Posted May 14, 2007 - 08:55 PM

#1

Just purchased a 01 YZ426, the cluch pull is very hard. Is this common. Went for a wood ride and my hand sore.

  • SRT426

Posted May 14, 2007 - 11:09 PM

#2

It's not an easy pull but it's not that stiff either. Try adjusting the lever position, you may have it to far from the grip for your hand size and the extra pull is causing the discomfort. Back out the adjuster so it hangs a bit looser and this should help. Also for woods riding gear down to 13/50 and you won't to use the clutch as much and it really pulls hard in tight conditions..

  • markvan

Posted May 15, 2007 - 08:50 AM

#3

I drilled out my clutch lever to move the position that the cable locks into, giving more leverage when the lever is pulled. There is also a longer actuater arm available, (01 or 02? not sure which year is longer than 00). I found that the lever modification made a big differance.....much better than before....

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • Gerry B

Posted May 15, 2007 - 08:57 AM

#4

try lubing your cable

  • frodaddy2921

Posted May 15, 2007 - 04:42 PM

#5

lube your cable and try a 400f clutch arm. its longer than the 01. made mine pull like a 250 two stroke:thumbsup:

  • 642MX

Posted May 15, 2007 - 04:58 PM

#6

Replace the cable. Its probably frayed somewhere causing the hard pull.





Related Content

 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.