xr650l smoking sputtering and stalling Please Help!!!!!


6 replies to this topic
  • tfb4me

Posted May 13, 2007 - 07:08 AM

#1

OK here is my problem...I have the 1994 xr650l it was running fine.Went for a nice road trip and noticed it was sputtering a little.Got it home and thought nothing more of it.I went on it again and it would hardly run and now it just sputters smokes then stalls.I checked the fuel shutoff valve it flows nice checked the float bowl it has fuel in it.Changed the plug tore down the carb cleaned it and now it seems to be worse.It will start and run untill it gets hot.Then nothing.It doesn't matter where or when it just stalls out.If I try to restart it it does nothing just turns over.If I turn the key off then back on again it starts right up then stalls almost right away.Im totally frustrated at this point and am ready to just kick it over but it might hurt my foot!!!Any help guys would be awsome cause im almost ready for the shop and $75 bucks an hour.Lost and going insane
Oh and I have put on a new Clarke tank cleaned both the carb and petcock.Any Ideas?

  • Motosprtman

Posted May 13, 2007 - 08:16 AM

#2

what color was the plug when you pulled it out? if it was dry black and sooty I am guesing it is ignition related and possibly the CDI box (as you mentioned the carbs are clean and set correctly and you have good fuel flow) weak ignition or improper timing will cause a black plug, that is the simplest thing I can think of, besides a clogged air filter.

What color is the smoke? if blue then your getting oil into the combustion chamber and the plug would of been oily black. The oil gets there via worn rings, valve guides or seals, this would be worst case and require a top end rebuild to fix. How many miles are on the bike?

  • martinfan30

Posted May 13, 2007 - 08:16 AM

#3

what color smoke? sounds like carb. issue especially if it got worse after taking it apart. if your needle is worn it will do this. high miles this is def. poss. may need new needle and jets.

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • tfb4me

Posted May 13, 2007 - 09:01 AM

#4

Ok the smoke is blue it is oil I know this.The bike has 32 thousand km not to sure what that is in miles.The plug was black and sooty However I was told it can run smokin for quite a while.I do need a top end rebuild.But I would like for it to run in the meantime.So im thinkin a carb rebuild kit or will a dynojet kit do the same job cause I was thinking of doing that.I will look into a cdi for iton monday.Just wish I could ride it's beautifull here today.
Oh and I just put a stock new air filter in it too.As you can see i have been pullin my hair out over this issue talk about frustrating.....

  • Bibleman

Posted May 13, 2007 - 09:29 AM

#5

If you had your carb off, make sure you reattached the choke cable! It will give the symptoms you describe if you left it off. Don't ask me how I know!:applause:

  • martinfan30

Posted May 13, 2007 - 10:53 AM

#6

how much oil are you burning?

  • tfb4me

Posted May 13, 2007 - 01:29 PM

#7

It is burning oil but not that much.It's hardly noticable on the dip stick.





Related Content

 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.