Oil in Frame?

5 replies to this topic
  • torrmentor

Posted April 25, 2007 - 02:30 AM


This is the second oil change I've done in the last three weeks (third change total, bike is brand new) on my '05 450 where I pulled the oil bolt from the frame and NOTHING came out. The dip stick is wet, the bike is functioning really well. Oil & filter had two rides & one race on them. Filter looked really good, mag drain plug & oil filter cover have some fine materials on them, but nothing out of spec. I filled the bike with the proper amount at the last change (I swear!!), so what gives with no oil purging from frame???:applause:

  • Pezman04wrx

Posted April 25, 2007 - 02:57 AM


Does it sit for a while before you change out your oil? ... From what I understand, the oil is only sucked up into the frame when it's running ... Once it has been shut off for a while it slowly works it's way back into the bottom end ... All is good as long as you're getting the right amount out of the bottom end and it's not litterally vanishing ...

  • MojaveThumper

Posted April 25, 2007 - 04:13 AM


Interesting, normally I get the opposite from mine. Very little out of all the other drains and a good deal from the drain bolt behind the front tire. This is the one you are talking about, correct? Only other place that makes a "mess" is the oil filter.

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • KJ790

Posted April 25, 2007 - 04:37 AM


If you don't start it before changing the oil then all the oil settles into the bottom end as stated before. Are you running it before you dump the oil?

  • torrmentor

Posted April 25, 2007 - 07:28 AM


Thanks guys, apparently before oil change #1 the engine must have been warm/run recently. Yes, the past few changes have been with an engine that had been sitting. Of course I run it to check the levels after filling, and then they show properly. I just wanted to make sure there wasn't a circulation problem.
All's good-thanks again!

  • grayracer513

Posted April 25, 2007 - 08:02 AM


There is a low pressure check ball between the oil pump and the rest of the feed circuit that is intended to stop oil from flowing back to the crankcase when the engine is not running. This only works in the short term, though, because the oil pump itself is not sealed, and oil, especially the lighter multi-grade oils we use these days, leaks slowly through the pump, past the the shaft, and back to the crankcase. Eventually, it's all there.

Related Content


Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.