06' Pressure in radiator ..!


2 replies to this topic
  • ragdoll-SA

Posted April 18, 2007 - 11:18 AM

#1

While preparing for a ride about 3weeks ago I checked my radiator level, when i opened the cap there wasa fair amount of pressure in the radiator. I thought nothing about it, went to the track the next day, while telling everyone about it i actually re-opened the cap and there was once again pressure in the radiator...?????:worthy: I hadn't started the bike since the prevoius evening..!!!
So i left it , rode the day at the track, didnt ride the following week (nor did i check it)..this evening i went to see whatsup with the radiator, as i opened it there was so much pressure in the radiator it actually sprayed out around 150-200ml ....
There is nothing in the oil...and it doesnt seem to be loosing water...:thumbsup:

There is just a load of pressure, could i have blown a head gasket, and if that's the case could there still be so much pressure after around 11days of not riding..??

Any ideas on &%$#@! could be causing this..:ride:

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • grayracer513

Posted April 18, 2007 - 01:51 PM

#2

Could be a head gasket. Probably not blown, but it may have lost its torque. Remove the cams and check the head bolts. If it's been leaking, you'll want to replace it.

  • ragdoll-SA

Posted April 18, 2007 - 11:09 PM

#3

I am going to pull the bike down and see what the issue is..will let know.





Related Content

 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.