wiseco pings


3 replies to this topic
  • TuningFork426

Posted March 04, 2007 - 08:57 PM

#1

my 426 pings what should i do?

will octane boost solve my problem?

Is pinging bad?

  • trailordune

Posted March 04, 2007 - 09:01 PM

#2

yes ...

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • Oasis_Flame

Posted March 05, 2007 - 11:06 AM

#3

Are you sure it's a ping? 91 pump gas is all you need. Are you sure you don't have a valve touching the piston? Valve lash is a major player here.

  • SXP

Posted March 05, 2007 - 02:25 PM

#4

my 426 pings what should i do?

will octane boost solve my problem?

Is pinging bad?


Good chance it's just a loose chain rapping on the slider, or a chain that has exceeded it's service limit doing the same. I know you are probably sceptical, but you owe it to your self to eliminate this as a source of the noise before you go any further. I was in the same boat as you and was damned to find out it was an out of spec chain! The chain rapping on the slider sounds freakishly similar to engine knock.




 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.