New starter clutch has packed in


3 replies to this topic
  • tvrjohn

Posted February 07, 2007 - 04:44 AM

#1

WR450 '04 replaced starter clutch , everything just fine.
Had a full days use no problems
Next time i went to get it out, starter spins ok but will not engage starter clutch and turn engine over.

What could the problem be ?

  • Indy_WR450

Posted February 07, 2007 - 04:58 AM

#2

03 was a bad year for starter clutches disintegrating. You may have got a replacement part that was made in that year. There seems to be some inconsistency with the manufacture of these starter clutches. Take it apart and if it has gernaded you got a bad one so go and try to plead with the dealer to get you another thru Yamaha marketing.:censored:

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • Douglas Bump

Posted February 12, 2007 - 04:46 PM

#3

I have a starter clutch for a 03wr450.

  • aussieallan

Posted February 13, 2007 - 05:46 PM

#4

I have 03 model gone through 2 starter clutches 1 kick start shaft . Not happy !




 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.