R-tard question


4 replies to this topic
  • steve_cirillo

Posted January 17, 2007 - 09:39 AM

#1

i just did an oil change on my bike, first time since i got my 426, i have only ridden it like 4 times. When i got it all done the clutch was super grabby, i mean like horribly grabby. i was pretty pissed. is this because i have too much oil in the bike? I drained all the old oil out and refilled it to fatory spec. Then when i got it out to the desert i rode it and progressivlyu through the day it got better. the only problem is im leaking orl from somwhere.. it looks to be comming from the head pipe or somewhere in that general vasinity. i checked the oil before i shut it off for the last time in the day and the oil level was perfect. and you wnat to know something else? the clutch was smmoth as silk. i may have answered my own question but now im wondering about that oil. i'll post pics later in the day. im new to the liqued cooled high preformance 4 stroke game.... flame away!!!

  • ausgeflippt13

Posted January 17, 2007 - 10:42 AM

#2

your clutch should be less-grabby with more oil. That's why wet clutches have so many plates: to compensate for the lubrication of the oil.

As for the oil, use a pressure sprayer on your bike to get rid of all the dirt and oil already deposited. Then, run the bike and watch for where the oil's coming from. One sorta neat trick is (once your bike is cleaned off) to apply a light layer of talcom powder or other whiter powder to where you think the leak is coming from. This will allow the oil to be better-seen, given that it's a darker color.

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • WGP

Posted January 17, 2007 - 10:42 AM

#3

What kind of oil did you use?

Don't know about the 426, but the oil leak could possibly be the Decompression Plug?:lol:

  • R_Little

Posted January 17, 2007 - 11:57 AM

#4

Dude, your bike has 2 drain plug. If you drain only the plug on the motor you will drop only about 1/2 the oil.

Make sure you take out the plug in the front frame downtube also and refill with 1.7 qts.

Sounds like you have too much oil in it.

usually the excess leaks out the big breather hose on the left side of the motor.

  • steve_cirillo

Posted January 17, 2007 - 12:21 PM

#5

Dude, your bike has 2 drain plug. If you drain only the plug on the motor you will drop only about 1/2 the oil.

Make sure you take out the plug in the front frame downtube also and refill with 1.7 qts.

Sounds like you have too much oil in it.

usually the excess leaks out the big breather hose on the left side of the motor.


yeah i drained both of the plugs.... 1.7 to spec and the oil is comming out of the right side of the bike.... i think i may be screwed




 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.