hot cam...lost my decompression?...

3 replies to this topic
  • thumpin hard

Posted January 07, 2007 - 02:28 PM


i had a local shop do a dynotune and a hotcam in my xr650l..seems to have a bit more power..but i looked at the cam and the paperwork and it seems to no longer have an auto decompression!! now it almost wont start when cold...can i add a manual decompression? or can i add an auto decompression to a hotcam?...(doubt that). thanks guys for the help..i have out chasing "pink snapper" instead of riding)..i am back

  • thumpin hard

Posted January 13, 2007 - 10:15 PM


ok, nobody wants to answer..or maybe the snapper comment..hmm..sooorrrryyy. i bought a 190 cca. battery and put a trickle does the job..the cam and rejetting helped and i went down to a 13 tooth counter sprocket..not bad.

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • Supafreak_711

Posted January 13, 2007 - 10:20 PM


Wish I would help ya...

I find the pink snapper comment humorous. They are probably my favorite type of fish...

  • thumpin hard

Posted January 14, 2007 - 07:56 PM


yeah the snapper is pretty favorite,just dont let your girlfriend catch you with it on your breath. lol.

Related Content


Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.