IMPORTANT-faulty 07 air filters...make sure yours is not the same.


133 replies to this topic
  • Hunter245x

Posted August 29, 2007 - 08:59 AM


I bought a 2007 wr250f in Aug of 2007 - ran it for around 10 hours before i noticed the hole in the air filter. I simply ran a set screw with a allen head into the hole with some lock tight. It looks like a permanent fix. Dust was in my carb so I removed it and cleand it in and out. How long do you think it takes until a problem can arise? Top end wear? 10, 20 50 hrs in dusty conditions. My bike still runs good but am worried about the long term. Any thoughts?

  • kodiak7

Posted August 29, 2007 - 09:54 AM


has anybody talked to yamaha about this yet.... im curious about what they have to say

  • chevytrkn1

Posted August 29, 2007 - 01:56 PM


Ya i just picked mine up last week, and it was the one with the hole all the way through, did not know to look at it tell i got it home. Just plugged it with a plastic push pin and high temp sillycone

  • debun

Posted August 29, 2007 - 06:54 PM


Ha s anyone found this on a YZ or is this only on the WR's

  • msgbean

Posted August 30, 2007 - 09:45 AM


Of course it on the YZs. That what the hole is for to put a bolt through.

  • debun

Posted August 30, 2007 - 01:30 PM


Of course it on the YZs. That what the hole is for to put a bolt through.


I looked at mine and I have a metal washer behind the screw so it doesn't seem like any dirt can get in. Am I missing somthing because I have a yz 250f 2007 and can't seem to find a problem

  • WR_Dave

Posted August 30, 2007 - 01:53 PM


You can't find a problem because on the YZ's the filter cage needs the hole for the bolt and washer, it's the WR's with the YZ cages that are having the issues.

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • slnutt

Posted October 11, 2007 - 05:08 PM


My bike is serial number 2355.....just bought it last week (October 2007). What are the chances that it has the updated cage?

Thanks

  • esbotto

Posted October 11, 2007 - 05:57 PM


50-50. Be on the safe side. Pull it out and make sure. I bought mine in February and they told me it had the right cage. Thankfully I just rode down the street before I pulled it out and discovered the hole.

  • camaroman7d

Posted January 12, 2008 - 08:59 AM


Just bought a leftover 07 last month and the filter cage is fine (no hole). Don't know if the dealer fixed it or if Yamaha finally has it figured out. I also don't know the build date. Where is that found?

  • maincrash

Posted January 25, 2009 - 06:43 AM


I just bought 07 wr450 used, got a great deal then i read this thread, grabed my flash light (11:30pm) out to the shed I go.
2700 km with a big old hole THAT SUCKS.
Oh well, starts good runs great I'll plug the hole and ride it.

  • mightymart

Posted January 25, 2009 - 12:58 PM


Problem solved!! An sponge ear plug with some loctite, stuffed the hole.


I did the same thing !
I also told Yamaha uk back in April 08 when I got the bike & they knew nothing about it :banana: Nor did they want to put it right, I must admit I had already pluged the hole & was hopeing for a freebie filter holder.

  • TRUE_2_YAMAHA_001

Posted January 25, 2009 - 10:56 PM


i don't know if they are suposto come out but mine does. which isn't saying much considering the topic. time for a uni filter to go on her.

  • mightymart

Posted January 26, 2009 - 05:34 AM


i don't know if they are suposto come out but mine does. which isn't saying much considering the topic. time for a uni filter to go on her.

Whats coming out ?




 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.