IMPORTANT-faulty 07 air filters...make sure yours is not the same.


133 replies to this topic
  • WR450_Mike

Posted January 06, 2007 - 05:39 PM

#41

Mine had the hole as well. I cleaned the cage real good and used carb cleaner down the hole. Then I passed the end of a shop towel down it to wipe it out good. Then I filled it with RTV. It ain't coming out.

  • WRLewis

Posted January 06, 2007 - 05:46 PM

#42

Just bought a 06 Wr450. Can you tell me if the filter has the same problem as the 07

  • clark4131

Posted January 06, 2007 - 08:21 PM

#43

Just bought a 06 Wr450. Can you tell me if the filter has the same problem as the 07


Uh, go look :lol:...SC

  • WR_Dave

Posted January 06, 2007 - 11:00 PM

#44

I hate to tell y'all this, but the air filter in ANY internal combustion isn't 100%. Granted, the hole down the new filter's center pin is bad news, but if you're expecting perfection once the problem is fixed, you're in for a huge disappointment. In other words, Dust Happens...SC


No filter gives 100% fitration but a hole gives 0%. No on is expecting perfection ,but we all expect all the air to be filtered to some degree. I agree with metal wizzard's last post. &%$#@!??? WR Dave.:lol:

  • clark4131

Posted January 07, 2007 - 01:17 PM

#45

I hate to tell y'all this, but the air filter in ANY internal combustion isn't 100%. Granted, the hole down the new filter's center pin is bad news, but if you're expecting perfection once the problem is fixed, you're in for a huge disappointment. In other words, Dust Happens...SC


To address the " ", I've highlighted the important line in my original post. I agreed the hole is a big problem. My point was that people seem to be flipping out over a light residue of dust, hoping for a sterile environment from a "perfect" filter. Not gonna happen is what I'm saying...SC

  • WR 911

Posted January 07, 2007 - 06:19 PM

#46

Thanks for the warning! I found my California bike has a hole as well. Being a mechanic for 18 years, I found an easy cure. Go to local hardware store and pick up a 5/16-18 x 5/16” socket head set screw and some JB weld. If you have a 5/16-18 tap, it will make the fix even better. Start at ether end and tap about ¼” into the filter housing. Next mix about a finger nails worth of epoxy and apply half into the hole then install the set screw finger tight. Lastly, apply the rest of the epoxy to the top of the screw to insure it won’t fall out. DUN!!!!:confused: :lol:

  • markhughesj

Posted January 08, 2007 - 04:20 AM

#47

I got a heads up through Dirtbike World Forum. News travels fast in cyber space. My WR450F 07 has the hole also. Lucky I have only done a couple of run in rides on my own.

Mark H
Bris Qld Aust

  • Beejay

Posted January 08, 2007 - 03:25 PM

#48

Guys if you're worried if dust got in take the float bowl off & check whats in the bottom.

  • gregwr450f

Posted January 09, 2007 - 03:42 AM

#49

Thanks for the warning! I found my California bike has a hole as well. Being a mechanic for 18 years, I found an easy cure. Go to local hardware store and pick up a 5/16-18 x 5/16” socket head set screw and some JB weld. If you have a 5/16-18 tap, it will make the fix even better. Start at ether end and tap about ¼” into the filter housing. Next mix about a finger nails worth of epoxy and apply half into the hole then install the set screw finger tight. Lastly, apply the rest of the epoxy to the top of the screw to insure it won’t fall out. DUN!!!!:confused: :lol:


Or get a replacement from yamaha:ride:

  • WR 911

Posted January 09, 2007 - 10:02 AM

#50

Can you say "Back order"? I'm not going to stop riding gust for a little hole!

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • Justa4stroken

Posted January 09, 2007 - 04:00 PM

#51

I called my dealer yesterday and talked to their service department. Their service guy went and looked at the other wr they have in stock and said it doesn't have a hole in it. SO They didn't believe mine did, and gave me Yamaha's phone number and said to call them. I called them and the lady there told me I was the third person that day to call about this issue.
The lady with customer service put me on hold for a few minutes to get a tech support person, and while onhold my dealers service man called back and appologized for not believing me in the first place. He said when he called tech support they knew exactly what he was talking about and gave him the number of the part to fix this issue. He said there is several of these out there and they are working on the problem.
In the mean time I've plugged the hole and siliconed it so I can use the bike until the new part comes in. Thanks to thumpertalk my new bike was saved from the dirt Gremlins. :lol:

  • Grimrieper

Posted January 10, 2007 - 04:06 AM

#52

Same problem in South Africa! Phoned my dealer and they are sending me a replacement asap. I however to a hilti wall plug and put that in the hole and that aint never coming out and is aperfect seal

  • beasly

Posted January 10, 2007 - 09:44 AM

#53

...
He said when he called tech support they knew exactly what he was talking about and gave him the number of the part to fix this issue.
...


Could you pass on the part number?

Thanks,
Rob

  • Justa4stroken

Posted January 11, 2007 - 09:17 AM

#54

I will soon as I get it.....

  • Dave Flanagan

Posted January 12, 2007 - 12:35 AM

#55

My 07 had the hole in it, California.
Dealer plugged it with a screw and sealed it up for me. They said 1/2 the bikes they had looked at have it and 1/2 are ok, just have to look.
Dave

  • prosports

Posted January 13, 2007 - 01:25 AM

#56

Hole in mine too.. In Canada. dealer had no idea.

  • corradok525

Posted January 13, 2007 - 02:28 PM

#57

Hallo guys Just bought in Italy 3 weeks ago.

also in mine there is a hole.

I bought the spare part and it has no hole, it is full/closed, abviously i replaced it.

apologize for my english

bye

corrado

  • Looks450

Posted January 15, 2007 - 04:10 PM

#58

I picked mine up yesterday. It had a hole in it. My dealer was not aware of the problem. Whilst my bike was being loaded i checked the 250 that was on the dealers floor and it was sealed properly. So i just swapped over the air filters, and problem solved.

  • ffgman

Posted January 17, 2007 - 09:31 AM

#59

I just looked at mine and it has the hole also. I just got done riding in heavy dust last week. Im over f----- joyed. There is a ton of dirt down that hole. I guess my rings are seated now. Yamaha ought to give my the parts for my first rebuild for free!

  • Kyle Prior

Posted January 17, 2007 - 09:01 PM

#60

I thought wat comes out the exhaust has to go in through the air filter.
I,m very happy with the bike apart from this issue
hope they will replace the cage at the least


When air and fuel combust in the chamber, the expand to a greater volume than they were before. They do this very quickly. That is how the power in your engine is made. When the air exits the engine, it is at a greater volume than it is when it enters. Also, air tends to be pushed at a faster rate than it is when it comes in.




 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.