'07 electric start problems

2 replies to this topic
  • Randy Nilles

Posted January 04, 2007 - 07:05 PM


I think this has been some what covered in a diferent thread, but I couldnt find it again.

My "07 doesnt want to start with the button very easy. I kicks fine and usually fires right away. With the button it just wants to spin and spin, and doesnt act like it wants to fire. If you give it a tad bit of throttle it does want to fire and sometimes does and sometimes it wont. It is doing this if the bike is hot or cold. I have done the air box mod, cut the grey wire, removed the small baffle, and took the trottle stop out.

I have a feeling it may be in the jetting. Any suggestions? Thanks in advance.

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • 123BigcoopDawg576

Posted January 04, 2007 - 08:06 PM


I have a feeling it may be in the jetting. Any suggestions?


  • 07wr250F

Posted January 04, 2007 - 08:14 PM


I don't have the 450 but I have the 07 250 and have done all of the similar mods. Prior to any modifications, I had similar hard starting issues.

Along with the free mods, I rejetted from a 170 main jet to a 178, changed from a stock needle to the JD red needle on the 4th clip position, and changed to an aftermarket fuel screw.

Since these mods the bike starts easily, usually on the first or second press of the button.

I have not done any of the AP adjustments but will be working with that next. So yes, as you felt and as posted above, work with your jetting.


Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.