650R quit?


12 replies to this topic
  • BigBoreRacing

Posted January 02, 2007 - 09:45 PM

#1

Was just rolling down the road and..Blaaaaa dead...no spark....no power to the coil, thinking CDI:excuseme: But maybe Stator:excuseme:

Light still flashes when I kick it...but testing the wires out of the stator only getting power on the two white wires?

I'm completly electronicly challenged:crazy:

Any ideas without having to buy parts till I find which one I needed?

Thanks.:lol:

  • porterdog

Posted January 03, 2007 - 05:03 AM

#2

There are places you can download the factory service manual online; if not here on TT try supermotojunkie or advrider. There's a troubleshooting tree in there that should help...

  • needsprayer

Posted January 03, 2007 - 05:18 AM

#3

Coil wire could be shorting to the frame.

  • BWB63

Posted January 03, 2007 - 06:56 AM

#4

There are places you can download the factory service manual online; if not here on TT try supermotojunkie or advrider. There's a troubleshooting tree in there that should help...


http://xr650r.boryna...650r_manual.htm

Haven't download it from here in a while, I hope this link still works.

  • BigBoreRacing

Posted January 03, 2007 - 04:44 PM

#5

thanks y'all...good stuff

  • InternalCombustion

Posted January 03, 2007 - 07:14 PM

#6

I hate elec problems, bigtime. Unfortunately there's no simple solution but to start at the spark plug and work backwards to the stator.

Odds are high the Ignition Pulse Generator on the stator, the stator CDI voltage output and Coil are all okay. That's the good news. The bad news is that proving all that is a real bear. Here's some simple tests:

1. The easiest thing to check first is to make sure your kill switch hasn't turned traitor on you. Remove it from the handlebar and try to start the bike. If it starts, your kill switch is bad and is shorting out.

Before running any of the next steps, pull the plug, reconnect the plug wire to the plug and ground the plug body against the engine case. This will allow you to do a quick and easy test for spark after each of the next steps. Just kick over the engine and check for a spark. If you have a cheapo spark tester it makes it a bit easier (NAPA, PepBoys, etc sell them for less than $10).

2. With the fuel tank off check the connection on the coil, both from the plug and the smaller (should be black-yellow) wire going from the coil into the wiring harness. Make sure there is no visible corrosion on either contact.

3. Next, make sure there is no significant rubbing on the harness shiething that the black-yellow coil wire goes into. Odds are you will not find any, but electrical problems require a very anal trouble-shooting process...

4. Now pull the seat and look for the 6-pin connector going into the CDI. Pull the plug-connector out of the CDI and check for any obvious bent pins or corrosion. Before you plug it back in spray a quick shot of WD40 into it and wipe any surplus.

If you still get no spark you might consider letting your favorite shop have a go at it.

I hope this helps, dude. Let us know how you progress.

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • BigBoreRacing

Posted January 03, 2007 - 11:59 PM

#7

Excellent stuff "IC" I'll keep you posted.
Done most of the above....and still nothing, I'd let the shop have a go of it if it wasn't 120 miles from me lol
I think I'll do a ohm check on it in the morning and see if the stator is doing what its supposed to do.............

  • pearblossomal

Posted January 04, 2007 - 10:37 AM

#8

Try disconnecting the black/white wire under the tank that goes to the kill switch. A friend's kill switch internally shorted going down the road in Baja with the same result, acted like someone hot the kill button.

  • pearblossomal

Posted January 04, 2007 - 10:51 AM

#9

I see a previous post about taking the switch off the bar and trying to start. That will work with a single wire kill switch but on a two wire switch (650R) you need to unplug the switch.

  • BigBoreRacing

Posted January 07, 2007 - 08:04 AM

#10

I think I've narrowed it down to the "Ignition Pulse Generator"....And if I'm seeing this right....I have to replace the the stator/IPG, Unplug up under the seat near the ICM and replace everything hooked to it...is that correct?

Thanks for everything TT:worthy:

  • InternalCombustion

Posted January 08, 2007 - 05:38 AM

#11

I see a previous post about taking the switch off the bar and trying to start. That will work with a single wire kill switch but on a two wire switch (650R) you need to unplug the switch.


Thanks for the correction, PBA, I missed that point in my original post. :lol:

  • InternalCombustion

Posted January 08, 2007 - 06:27 AM

#12

I think I've narrowed it down to the "Ignition Pulse Generator"....And if I'm seeing this right....I have to replace the the stator/IPG, Unplug up under the seat near the ICM and replace everything hooked to it...is that correct?

Thanks for everything TT:worthy:


Bummer. My understanding is that you cannot buy a new pulse generator by itself, as you correctly say you have to replace the entire stator assembly. This parts schematic shows the complete assembly.

I had an intermitent problem last year on my R, couldn't figure it out, everybody telling me that the Pulse Generator rarely goes bad. My issue was that I had recently done a lot of wiring upgrades for dual-sport lighting, tach, blah-blah, and I was not 100% confident in my wiring connections. So before I replaced the stator/pulse generator I replaced all of my previous wiring job and used OEM connectors instead of my crap-ugly soldering/crimping connections. For me that did the trick. Obviously if you've not done any previous wiring on your bike this probably will not apply to your situation.

When/if you've pulled your stator cover did you notice anything unusual? If you are going to replace the stator be sure to buy the stator-cover gasket. Most of them will stick to one side or the other, and tear when you try to get them off.

PS: My alter-ego, "Project Guy", cannot help but suggest that if you are going to all this trouble you also should consider rewinding your stator to pump up your output and lighting options.

"Project Guy" is a real bastard to live with, sometimes. But sometimes he turns out nice bikes. My wife thinks he's just a deranged mofo. FYI, "Project Guy" posted a complete electrical schematic of my modded R, in My Garage. If you have masochistic tendencies you will be interested in this schematic. Otherwise it is best viewed only when sitting down.

  • Fngeniusshan

Posted January 08, 2007 - 10:22 AM

#13

IC,
I just looked at your bike and I agree with your wife: You are a deranged MoFo. Thanks for the help with BigBore's bike. We have riding to do! FnShan-GRMA





Related Content

 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.