need Help

3 replies to this topic
  • aightball27

Posted November 17, 2006 - 08:30 AM


i have a wr450 with the mods and a gytr pipe. when i give it gas of the idle the bike stalls. any suggestions.

  • simon@vic

Posted November 17, 2006 - 11:14 AM


that could be 100 things! you need to be WAY more specific about the problem, what has been done, and bikes background.

bring it to a shop! or take a motorcycle mechanics course.

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • trailordune

Posted November 17, 2006 - 05:27 PM


Do a search for bog or off idle bog, you'll find tons of info. You have jetting issues. Look into the leak jet, maybe needle position.

  • boer

Posted November 18, 2006 - 07:40 AM


This seems to be a common problem from what I perceive. If your pilot circuit, needle and main jet are dialled this bog should only be evident at snapping the throttle really quickly at idle and not in actual riding circumstances. Some guys have samller leakjets and different accelerator pump covers or stiffened up the link on the accelerator pump. Do some searching, you will be surprised what you find.:cheers:


Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.