XR650R throttle cable spring


9 replies to this topic
  • NEW2XR

Posted November 09, 2006 - 03:44 AM

#1

Hi, I was trying to fix my throttle - would not spring back to shut if you opened it and let go. Tried lubing the cables and checked the carb to see if something was sticking but the carb was fine so I'm assuming more lub on the cables. My prob is getting the throttle barrel spring back on and its driving me nuts!!. I know it can do it cos I changed the jets on another 650R I have an managed to get the spring back on, but with some difficulty - can't remember how I did it. Anyhow, is there a technique to it for doing it with one person or do you need 2 pairs of hands. Spent about 2 hours last night clipping the spring in position with the shaft extended out of the carb, but every time I nearly got the shaft back in with throttle closed, all I got was the deadly 'ping' sound of the spring unseating from clip arrggghhhh!!! Is there a nack to this that works or do I just have hooves for hands

Any help much appreciated

  • eastreich

Posted November 09, 2006 - 07:40 AM

#2

If it makes you feel better, and it probably doesn't, I know that I have spent a lot of time doing the same thing that you have. I don't know of an easy way to do it, but if you can find a way to get someone else's hands in there to help, you could try it.

I have done it by putting the arm all the way back in and then pulling the spring back around under tension with a pair of needle nose Vise-Grips to get it hooked up. It still wasn't easy, though.

  • saintvice

Posted November 09, 2006 - 07:51 AM

#3

well,
i had a similar problem a few months back. everythin seemed fine.. lubed cable.. tension was right.. everything then i gave up and called a mechanic friend of mine.. he had worked on an xr before.. and all he did was relocate the throttle cable.. and it worked ... so if u have repositioned the cable that might be ur problem.. hope it helps..

  • XR4DEZ

Posted November 09, 2006 - 10:20 AM

#4

Are the cables moving freely in the jacket? If not, then you need new cables.The cables should fall through on their own without being pulled.Make sure the cables are routed close to the top of the frame and are not hung up on or under the tank mounts.Rotate the throttle back, run the cables down next to the oil fill cap and back to the carb so the cables have less tension. Could be the throttle tube hanging up on the bars?

  • NEW2XR

Posted November 10, 2006 - 12:52 AM

#5

Thanks for the responses. Got the spring back on last night - was much easier seating the clip on the barrel first then pulling tension and seating the clip at the carb last - I was doing it arse about face which I think was the problem. The wire loop from the seat/tank clip was handy for pulling tension in the spring to a position where I could get the long nose pliers at it. Anyway whe all back together, still no different. The cables seem in good enough order, I also checked the cables were not fouled up in the guides within the throttle assembly, but all seemed ok. Only thing left to check is the routing of the cables as suggested by saintvince and xr4dez, thanks for that - just out of curiosity (and without sitiing in front of the bike as am in work) why would cable routing cause this if the cables and cable jackets are the same length no matter what route, as long as not being stretched/pulled like if being fouled up when turning bars?

Cheers

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • saintvice

Posted November 10, 2006 - 05:23 AM

#6

same thing i asked myself.. but with no proper reason and no scientific explanation it worked... and i am very grateful for it... so if someone can explain why it causes such a big difference i would be more than grateful.

  • redryder03

Posted November 10, 2006 - 02:28 PM

#7

Also make sure your throttle tube is moving freely and not binding or rubbing against your handguards.

  • eastreich

Posted November 10, 2006 - 03:18 PM

#8

I have had problems with what I thought was the cables or throttle binding before and been stymied by the throttle tube like redryder03. It was actually my billet throttle tube catching on the edge of the bolt that holds my wraparound handguards into the end of my bars.

  • XR4DEZ

Posted November 10, 2006 - 05:31 PM

#9

You want to route the cables along the shortest distance between the throttle and the carb, it reduces binding and cable pull when turning.

  • redryder03

Posted November 11, 2006 - 08:02 AM

#10

I have had problems with what I thought was the cables or throttle binding before and been stymied by the throttle tube like redryder03. It was actually my billet throttle tube catching on the edge of the bolt that holds my wraparound handguards into the end of my bars.


:cheers: Yup





Related Content

Reviews

Honda XR650L 2017 by Chris.GVS


Honda XR650L 2017
  • - - - - -
  • 0 reviews
Forums
Photo

Post Apocalypse, ThumperTalk style! by Justin Pearson


Dirt Bike   General Dirt Bike Forums   General Dirt Bike Discussion
  • Hot  35 replies
Reviews

Honda XR650L 2016 by Chris.GVS


Honda XR650L 2016
  • - - - - -
  • 0 reviews
Forums
Photo

Engine Loping/Sputtering by tcaldwell


Dirt Bike   Make / Model Specific   Honda   XR600/650
  • 2 replies
Forums
Photo

ignitech programmable XR650L CDI by brianhare


Dirt Bike   Make / Model Specific   Honda   XR600/650
  • Hot  60 replies
 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.