Devol Radiator Guards



6 replies to this topic
  • Cuda

Posted December 19, 2001 - 06:05 AM

#1

Has anyone had trouble mounting the Devol guards? I just installed a set and the lower shroud mount doesn’t line up to the mount on the guard. The bracket is installed using two screws and seems to be to far forward. The shroud-mounting hole is about one inch short of the bracket. If I move the bracket back and use only one screw they fit ok but push the shrouds out a little no biggie. I called Devol and got the standard answer "We have sold thousands of these guards and you are the first to have a problem" I just can't see how these could work they must have miss drilled my set they fit perfect all but the shroud mount? :)

  • crs

Posted December 19, 2001 - 06:12 AM

#2

Cuda,
I have a set of those guards and they mounted and fit great. Maybe step back look at it again and make shure you are putting them together correctly, and if so send them back because they shoud fit right.

crs

  • YAMAKAZE

Posted December 19, 2001 - 06:15 AM

#3

Agreed....Mine looked like they were wrong initially....(Lack of installation documentstion) but after taking the bracket and trying this and that, I figured it out. Your distributer could have ordered the wrong set....could happen...

Good Luck..

Bonzai :)

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • Cuda

Posted December 19, 2001 - 06:37 AM

#4

CRS, Yamakaze,
Are the holes for your brackets off set forward of the rear mounting support bracket?

[ December 19, 2001: Message edited by: Cuda ]

  • YAMAKAZE

Posted December 19, 2001 - 07:10 AM

#5

Honestly I cannot remember, But I will look at them this evening .I can e-mail you a photo if you send me your address.

Bonzai :)

  • Hick

Posted December 19, 2001 - 01:23 PM

#6

Cuda,

I think you either:

a) Were sold ’98 – ’99 model guards by mistake.
:) Have a bent radiator. With the rad mounted grab the edge and pull back until the shroud lines up.

Whenever I’ve had problems reinstalling my shrouds it is because the radiator is tweaked a bit to the fore or aft.

Hope this helps.

  • Dave_VanBrocklin

Posted December 19, 2001 - 04:54 PM

#7

I agree with the bent radiator. When I installed mine, I was sure I was sold YZ guards, but after I "adjusted" my radiators, they fit fine.Good Luck!!
Dave




 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.