2005 WR450 Hard starting since free mods


3 replies to this topic
  • kmalec

Posted October 26, 2006 - 03:45 AM

#1

Hey,

I made all the free mods, plus the throttle screw to my WR450, I also put in the promotobillit exhaust insert. It runs now, however its very hard to start. I have to kick it a long while. It wont turn on the electric start before it runs down the battery. I choke it, gas it, it will take a long whiel to start. When its warm theres no problems. Is this a jetting issue? I havent jetted it cause it didnt seem to need it. Its got 276 miles on it, hasnt been back to dealer yet, i was waiting for spring at 500 miles.

Thanks,

Keith

  • Alley Cat

Posted October 26, 2006 - 04:49 AM

#2

Definately a jetting issue, put in a 48 pilot jet and it should be a lot better mate. It has a (smallish) 45 pilot jet stock.

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • clark4131

Posted October 26, 2006 - 05:19 AM

#3

I agree with AC, but before you mess with any of the jetting, consult the database at the top of the forum to get an idea what you'll need for your bike. Hard starting can also be indicative of a need for a valve adjustment. You're right about at the right mileage for a break-in check and likely in need of a re-shim on one or two valves...SC

  • kmalec

Posted October 29, 2006 - 04:52 AM

#4

Thanks guys, I will look into both.




 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.