needed; clutch diagnosis


4 replies to this topic
  • tdavid

Posted October 23, 2006 - 10:32 AM

#1

Mates,
During a really hard ride my 2005 WR450 clutch lever would periodically not engage. A few minutes later it worked fine only to be followed by further difficulty pulling in the clutch lever. Does anyone have any ideas and/or solutions? This is the first time I have run into any difficulty with the clutch.

Thanks for the help!

  • NYMXer

Posted October 23, 2006 - 11:08 AM

#2

Does it ever work normal? Did you check the cable for fraying and wear? If that's good, an oil change could help. Otherwise, it's clutch time.

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • JRAMBO

Posted October 23, 2006 - 11:13 AM

#3

Yep check the cable if thats OK get a cable lubing tool and lube it.

  • tdavid

Posted October 23, 2006 - 11:25 AM

#4

the clutch works fine now. the bike doesnt have a great number of hours on it and i doubt the clutch is toast. i was wondering what are the causes of a lever not able to be pulled in freely? the cable is not frayed either.

  • NYMXer

Posted October 23, 2006 - 12:49 PM

#5

If your lever free play is not adjusted properly, all kinds of funny stuff can happen. Double check the lever free play and change your oil too. :mad:




 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.