XR650L Choke Question


6 replies to this topic
  • obiwanblee

Posted October 14, 2006 - 02:45 PM

#1

I just got my hands on a '94 XR650L but I seem to be having problems with the choke. When I pull it towards me (I think this is turning the choke on?) with the cable showing, it idles much lower than when the lever is closed (choke off?). In fact, with the lever closed all the way towards the bike, it sounds like it's fast idling or even revving slightly. Maybe I have this backwards? The bike also surges when on the throttle and I'm not sure where to start looking for that problem.

Sorry if these are really stupid questions, but the last time I was on a carbed bike was in MSF and they are a complete mystery to me.

  • rebelventurer

Posted October 14, 2006 - 04:12 PM

#2

yep, pull the lever towards the handlebars and you are choking it push away and your not! Surging sounds like carb issues, probably some shilack(spelling) dried up gas deposits in the carb partially blocking passages in the carb! Check the air filter first make sure its relatively clean. Oh, welcome to TT, lots of people here that know their stuff so if you wonder about something, just ask. Has it been parked for a while?

  • obiwanblee

Posted October 14, 2006 - 06:01 PM

#3

Hmm, that's weird then. Why would it idle higher when the choke is off? I have no idea how long the bike was sitting, what I do know is that it was unable to start for a while because of a dead CDI, which I replaced.

The choke thing concerns me quite a bit, since the bike seems to be functioning opposite of what the choke lever is doing, unless it's normal for the XRs to idle higher with the choke off.

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • obiwanblee

Posted October 15, 2006 - 05:07 PM

#4

Bump!

  • brichter

Posted October 16, 2006 - 02:55 PM

#5

Sounds like you got some crap in the carb, probably time to clean them or it's just set way too ricvh at idle. What color is the plug?

You pick it up off CL?

  • rebelventurer

Posted October 16, 2006 - 02:58 PM

#6

Bump, what!
when mines warm, wont idle at all with choke!

  • cleonard

Posted October 16, 2006 - 03:52 PM

#7

I can think of two possible issues. Crap in the carb like others have suggested, or an air leak. With the bike warm and idling spray some carb cleaner on the ends of boot between the carb and the engine. They usually leak where the boot attaches to the engine. When the carb cleaner hit a leak it will cause the engine speed to change as the carb cleaner gets sucked in.

If the bike was sitting and there was gas in the carb, it needs some cleaning for sure.





Related Content

Forums
Photo
Washington

Cle Elum Sunday 5/29: Looking for dual sport tips by TigerTanker


Dirt Bike   Dirt Bike Regional Discussion   Northwest
  • Hot  32 replies
Forums
Photo

2015 XR650L Squeaking noise by Crayjay


Dirt Bike   Make / Model Specific   Honda   XR600/650
  • 3 replies
Forums
Photo
Supercross

Supercross Preview 2017 Part 1: Championship Contenders by Chris Cooksey


Dirt Bike   Special Interest Forums   Pro Racing
  • Hot  148 replies
Forums
Photo

ignitech programmable XR650L CDI by brianhare


Dirt Bike   Make / Model Specific   Honda   XR600/650
  • Hot  60 replies
Forums
Photo

Engine Loping/Sputtering by tcaldwell


Dirt Bike   Make / Model Specific   Honda   XR600/650
  • 2 replies
 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.