426 tank is cracking!

No replies to this topic
  • atropine

Posted September 21, 2006 - 09:27 PM


I went out to the garage yesterday and the 426 didn't want to start up right away. So I went to take off the tank to change out the spark plug, and discovered that my tank is cracking. Same spot on both sides, in a horizontal line right at where the radiator shroud bolts into the top of the tank. The cracks are almost hidden by the shrouds, but when you take them off the cracks are pretty obvious. I can't tell if the cracks go all the way through the tank. They are each about 2 inches long. I have never wrecked the bike or laid it down, and I'm 99% sure these cracks weren't there last time I had the tank off (about 2 months ago). I don't think I have overtightened the screws that hold the shroud to the tank. Anyone ever seen this before? I suppose I could mix up some JB weld and smear it into the cracks (they are not big enough to allow JB weld to get into the fuel) to seal the holes. A better fix would be to just buy a new tank; I would kind of like a higher-capacity tank anyway. After searching on here, it looks like IMS is the way to go. Blue, natural, or white? The IMS website doesn't seem to have pics of the tanks on those colors for my bike. Anyone have pics of an IMS 426 tank in these colors?

Related Content


Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.