XR650L horn won't work when idling?

8 replies to this topic
  • twerner

Posted September 05, 2006 - 06:19 PM


Horn and blinkers will only work at high rpms.
What could be the cause? Stator? Regulator?
Just installed a new battery.

  • LotsOfBikes

Posted September 10, 2006 - 10:42 PM


More info will help.

Hook a volt meter up to your battery with the bike running. See if there is a voltage difference at the battery:

1. Not running, ignition off
2. Ignition on, not running
3. Engine idling
4. Engine revved up

You might have something loose or just not connecting right.

  • reduceus

Posted December 07, 2008 - 03:31 AM


I have a brand new XR650L and it has a similar problem - at low engine revs the lights, indicators are ok but the horn refuses to sound. I have to give it a handful of revs to make it work - should this happen on a new machineI

  • wattner

Posted December 07, 2008 - 06:38 AM


that sounds like a grounding problem!!!

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • martinfan30

Posted December 07, 2008 - 08:04 AM


If it's new, take it back to the dealer!

  • reduceus

Posted December 08, 2008 - 01:27 AM


Would love to be able to take it back to the dealer, but it would be a very wet journey - He is in Tampa, Florida - I am in The Gambia, West Africa. Could you suggest a suitable route please?
Have tried the earth(ground - all ok). The horn (crappy as it is) works fime when the revs are up but stops working when you let the throttle go - odd!!!

  • Kenzo

Posted December 08, 2008 - 06:23 AM


sounds like a simple battery problem...sometimes the obvious gets overlooked :smirk:

check, clean & tighten ur battery connections...can't remember if the stock battery is sealed or not but if it's unsealed check the fluid levels...

if that does not correct the problem test the battery...it may be failing or faulty.


  • scalejockey

Posted December 08, 2008 - 07:32 AM


On the back of the horn will be a small screw with and a lock down nut. Try and adjust it in and out,that sometimes will bring a horn back to life.

  • reduceus

Posted December 15, 2008 - 09:35 AM


Thanks for the advice, have finally had time to play - the problem was the horn, it's crap. Why put such a puny thing on a BRP, may save Honda money but it looses brownie points on quality.
Have just ordered a Stebel Magnum, 136db - locals should hear that.....

Related Content


FCR40 Tuning Woes- XR600R by aTuWitty

Dirt Bike   Make / Model Specific   Honda   XR600/650
  • Hot  37 replies

Which thumper motor for a street tracker? by woz

Dirt Bike   General Dirt Bike Forums   General Dirt Bike Discussion
  • * * * * -
  • Hot  29 replies

Can anyone identify this xr600 piston? by ms_mtn24

Dirt Bike   Make / Model Specific   Honda   XR600/650
  • 4 replies

93 xr650l Restoration Project by Zigster

Dirt Bike   Make / Model Specific   Honda   XR600/650
  • 17 replies

Wiseco 101MM Spark Knock Low Engine Temps by imandrewparks

Dirt Bike   Make / Model Specific   Honda   XR600/650
  • 7 replies

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.