off idle bog


3 replies to this topic
  • mfracing19

Posted August 31, 2006 - 04:16 PM

#1

YFZ 450 with no cam mod. Has a Dr.D Pipe with a GYTR header, K&N filter with pro flow and air lid removed. Im at 6000ft elevation and can't seam to get it jetted right. I think this is causing my off idle bog. Any suggestions?

  • grayracer513

Posted September 01, 2006 - 07:56 AM

#2

Check out the Jetting Database that's stickied to the top of the index.

I don't really care for K&N filters at all (they're too hard to service, and they don't filter well if they don't get oiled right). YZ450 air boxes had no lid. What did you remove?

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • ben_suhard

Posted September 01, 2006 - 10:38 AM

#3

YZ450 air boxes had no lid. What did you remove?

He said YFZ 450...sounds like it might be a quad?

  • grayracer513

Posted September 01, 2006 - 02:22 PM

#4

So he did. In that case, he's in the wrong forum. Some of the quad guys in the YFZ forum should be able to help him.





Related Content

 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.