bk mod problems

1 reply to this topic
  • codyblanchard

Posted August 01, 2006 - 04:54 PM


I just finished doing the bk mod and it hasn't cured the bog when I open the throttle quickly. I have tried adjusting it both ways and think I have the best response now. Adjusting the fuel screw also doesn't seem to help. It definately responds better when the throttle is opened, but the bog is still there. When opening the throttle from anywhere above 1/3 the response is great. What else can I try to fix this problem? The bike is an '00 yz426 that is all stock. I don't know what the jetting is, but can check if need be. I ride between 2500 - 4000 feet elevation.



Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • Fastest1

Posted August 01, 2006 - 06:53 PM


It will definitely help to know all jets, pilot jets, and needles. I would think the pilot is the wrong size by what you have described, mostly because you stated the "fuel screw does nothing" This is ususally the case if the pilot is out of range. I would personally buy the JD Jetting kit and be happy. You can get there other ways but it will take a bit of trial and error. Have you posted in the jetting forum?

Related Content


Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.