What to Expect.

5 replies to this topic
  • BIGchiefKODIAK

Posted July 06, 2006 - 09:57 PM


Well the used 04 Wr I recently purchased has a problem. Seems to be not that much power. Started first kick everytime and ran perfectly for a week and half. The other day it was dying whenever I pulled the clutch. So at a stop light I was adjusting idle and it died. When Tryed to start it was smoke from under the engine could not tell where exactly, Had to move for traffic. Ifound the decompression rubber plug had fell off, put that back on. Now seems to run really really hot. When I get to destination and shut the bike off it leaves a puddle of milky oil. Did this 3 times and know it is parked until I get it checked out. My buddy gave me his yz cam, he put in a hotcam. So this weekend I am taking to dealership to have the cam put in and get it jetted,and looked over really well. I do not know that much about the engine stuff,YET. The guy I got it from just had vavles adjusted. I hope the motor is not shot. Anyone have a guess on what it could be? I do not want to put in shop then get charged 1500 bucks. If it is shot i will just blow it up then bore it.
thanks. :ride:

  • Thumper_Bloke

Posted July 06, 2006 - 10:21 PM


Have you changed the oil, and checked the coolant level?

  • BIGchiefKODIAK

Posted July 06, 2006 - 11:05 PM


yes all is well. changed oil when I got the bike coollant is okay. no holes in radiator. Did not overfill oil. Seems to have oil leaking from the head gasket area.

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • hartzpad

Posted July 07, 2006 - 05:36 AM


anytime you hear mention of "milky oil" it should set off red flags in your head. If the oil is milky (which it shouldn't be) you have a problem somewhere and it is usually due to coolant somehow getting mixing with the oil through a blown head gasket or something else. Don't run it with the oil contaminated like that.

  • Frank_z28

Posted July 07, 2006 - 09:17 AM


do not ever run with coolant in your oil. Coolant + bearing = mess.

  • BIGchiefKODIAK

Posted July 07, 2006 - 11:28 AM


I am not like I said the bike is parked, until the dealership checks it out. Just wanted to know if is going to be a mess.


Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.