WR & YZ CDI Interchangeability (2003+)

4 replies to this topic
  • SpeedBlitz

Posted June 28, 2006 - 08:08 AM


From the searches I have made, it seems that the YZ and WR CDIs don't interchange, but the info I found appears to be mostly for 98-02 WRs & YZs. Does anyone know about the 2003+ 450s?

Basically, I'm trying to troubleshoot a problem with my 03 WR450 (http://www.thumperta...ad.php?t=390374) and I would like to borrow a friend's CDI from a 2004 YZ450 to check if the CDI on my 2003 WR450 is gone or not.

Does anyone know if I can simply plug the YZ CDI on my 03 WR? The 2003 & 2004 WR list the same P/N for the CDI, but the YZ lists a different P/N from the WR and also changed from 2003 to 2004. Does anyone know what the second and third digits of the P/N mean? I want to try a 2004 YZ CDI on my 2003 WR.

2003 YZ450F 5TA-85540-00-00 C.D.I. UNIT ASSY
2004 YZ450F 5XD-85540-00-00 C.D.I. UNIT ASSY
2003 WR450F 5TJ-85540-00-00 C.D.I. UNIT ASSY
2004 WR450F 5TJ-85540-50-00 C.D.I. UNIT ASSY


  • Stripes123

Posted June 28, 2006 - 12:16 PM


I also had problems with the CDI on my 2003 WR250F and although I don't recall what the specific difference was between the WR and YZ CDI's, they don't interchange.

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • SpeedBlitz

Posted June 29, 2006 - 04:57 AM


Thanks Stripes. I was actually going to install a friends carb to see if it solved the problem and try his CDI as well, allowing me to isolate the problem, but I decided to check a few other simple things, and surely enough, it was a faulty kill switch! The intermittent starting and idling at high RPM only really threw me, but it was the kill switch!


  • BergArabia

Posted June 29, 2006 - 05:05 AM


So how did you finally identify the kill switch problem, did you bypass it?

  • SpeedBlitz

Posted June 29, 2006 - 11:29 AM


So how did you finally identify the kill switch problem, did you bypass it?

Before going any further, I decided to go back to basics, even though I thought I had covered the basics. So I checked for spark, and I only got a spark once in a while. I tried another plug and the same. So I figured since it fires intermittently, it's not a timing issue and a CDI tends to completely fail, not run intermittently (or so I hear), so I thought it would be either CDI feedback issues from the TPS or pickup coil or a wiring/switch issue. So I just followed the service manual on checking for an ignition problem. I checked for continuity of the kill switch and it had continuity when depressed and free, and with the kill switch unplugged, the bike started and ran great. I put in a spare switch and it runs great. After, I spoke with a friend that has been racing for many years and he told me that whenever he suspects an electrical problem, one of the first things he does is disconnect the kill switch.


Related Content


Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.