questions JD?



90 replies to this topic
  • stevethe

Posted February 26, 2016 - 12:57 PM

#81

Hey guys I need some help just bought a Orion 125cc pitbike..... And the air filter that came on it has a vacuum line going to the motor.... I'm trying to find a air filter that has a line connected to it and that is better quality because the one that came on it was a pos..... Or is it possible to just not have the vacuum line? So I can put just a regular air filter on it? Please help I'm so confused thank you


You might want to post that in the Chinese section here http://www.thumperta...um/207-chinese/

Your other bet would be to go to the nearest dealer and ask them.

  • Yzrippa177

Posted March 02, 2016 - 05:46 PM

#82

Was i connected to anything when u took it apart? Try running it without it hooked up if it runs like shit than it needs to be connected look for a fitting on the airbox or by the carb

  • digemin

Posted March 26, 2016 - 01:24 AM

#83

Hi guys I've recently picked up a 2000 yz400f it has a issue with the gear selection it won't go into neutral and if it does happen to find neutral as soon as you try to start it it jumps into gear any help would be great

  • Krannie McKranface

Posted March 26, 2016 - 06:36 AM

#84

Hi guys I've recently picked up a 2000 yz400f it has a issue with the gear selection it won't go into neutral and if it does happen to find neutral as soon as you try to start it it jumps into gear any help would be great

 

Wrong forum



  • krashCrazy

Posted June 15, 2016 - 02:42 PM

#85

I have no idea where I'm supposed to post my question at but I have a ttr125 I think its a 96 but it starts with one kick every time and idles great I just can't get it to rev out in first or second it ran great when I test rode it but after I bought it the damn thing just wont act right any help will be greatly appreciated

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • Krannie McKranface

Posted June 15, 2016 - 02:59 PM

#86

I have no idea where I'm supposed to post my question at but I have a ttr125 I think its a 96 but it starts with one kick every time and idles great I just can't get it to rev out in first or second it ran great when I test rode it but after I bought it the damn thing just wont act right any help will be greatly appreciated

 

http://www.thumperta...m/forum/24-ttr/



  • Yzrippa177

Posted June 15, 2016 - 03:59 PM

#87

When do u mean by rev out? @krashcrazy

  • bhall1122

Posted June 19, 2016 - 07:44 PM

#88

Yea I was wonderingnif anyone knew if the part- 51450-kz3-j41 still exists. Or if its an interchangeable part off newer models. Also called a front fork bolt assembly. Please help

  • HongKong250

Posted June 28, 2016 - 07:26 PM

#89

Can a mod please changey username to HongKong250? Mistake on signup. Thanks brah!

  • jabronicrf250r

Posted July 10, 2016 - 09:21 PM

#90

I have a 2008 Crf250r would 2008 crf450 graphics fit it?

  • BS22

Posted July 11, 2016 - 09:31 AM

#91

I have a 2005 yz125 & the right power valve is broke & I was wondering if a yz250 power valve could work & I only need the valve and nothing else. I forgot to mention that the Head & Jug are Athena 144 with Stamped ( A )




 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.