My XR650L is stalling?


2 replies to this topic
  • SASK_TK

Posted May 25, 2006 - 12:19 PM

#1

I was on the highway the other day and my XR just dies. I pulled over, checked to make sure i didn't run out of gas, tried staring it, and it fired up. I continued on my way and a few miles down the road the same thing happened. I was close to home so I switched over to reserve and made it home.

Taking a closer look I couldn't see any problems, but found that after a few minutes of just idling it stalled. But seemed fine running on reserve. Any ideas? It's a 2002 and all stock for now, I'm just about to do Dave's mods, pipe etc. Is there just a screen (maybe plugged) in the fuel line at the tank or is there a filter I'm not seeing?

Any help would be GREAT!

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • XR650L_Dave

Posted May 26, 2006 - 08:27 AM

#2

I was on the highway the other day and my XR just dies. I pulled over, checked to make sure i didn't run out of gas, tried staring it, and it fired up. I continued on my way and a few miles down the road the same thing happened. I was close to home so I switched over to reserve and made it home.

Taking a closer look I couldn't see any problems, but found that after a few minutes of just idling it stalled. But seemed fine running on reserve. Any ideas? It's a 2002 and all stock for now, I'm just about to do Dave's mods, pipe etc. Is there just a screen (maybe plugged) in the fuel line at the tank or is there a filter I'm not seeing?

Any help would be GREAT!



There's a filter in the tank, and there's another under the little bowl that screws out of the bottom of the petcock.

Could be fuel-tank venting, a pinched line, or a plugged breather hose on the carb.

Reserve raises the pressure of the fuel in the line, so a restriction is a good bet.

Dave

  • noeford

Posted May 29, 2006 - 06:17 PM

#3

Hello, I had a stalling issue too. I bought a new cdi unit and it fixed the problem. It would stall at idle, riding and sometimes would run for a while! The cdi is located next to the battery it has two plugs that plug into it. Pull the cdi out while engine is running and touch the wire plugs! Move cdi arround and see if it stalls. Mine would stall when I touched cdi or wires! Let me know what you find out.
Steve





Related Content

 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.