WC Radiator Braces


8 replies to this topic
  • kpflyingv

Posted May 21, 2006 - 08:45 AM

#1

I just recieved a set of rad braces for my 06 YZ450F. They don't come close to fitting. I think they are YZ250F braces packed by accident in a 450F package. [B]Does anyone know if the 250 and 450 rad mounting holes are different?[/B] The braces are about a quarter inch short in length on hole alignment.
Every other product I've got from WC has been excellent, so I think there's some kind of packaging error.

  • FriscoKLR

Posted May 21, 2006 - 09:25 AM

#2

My WC rad guards fit my 06 450 perfect. Must be a mis-marked package.

  • kxman

Posted May 21, 2006 - 11:42 AM

#3

I put a set on last week. Fit and workmanship was excellent.

  • sharky_do_do

Posted May 21, 2006 - 06:14 PM

#4

Actually it could be a good thing they don't fit, send them back, get your money back....then go out and get a set of Devols.

The Devols are much, much, more stronger than the WC's...especially the way the radiators hang down so much....

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • kpflyingv

Posted May 21, 2006 - 06:19 PM

#5

I really want to stay with WC. I'm sure it was a packaging mistake and they'll make it right. The other stuff I've gotton from them has been top notch.

  • cowboyona426

Posted May 21, 2006 - 10:06 PM

#6

kpflyingv, contact Shawn at WC, his extension is 201 I believe. My cages didn't fit quite right on my 06 either, and he was very helpful in trying to help me sort out the problem. He even sent me a new skid plate at no charge because I told him how the first one I got didn't fit quite right, then threw a set of fender stickers in on top of it! :ride: The problem I had was the lower shroud bolts were a pain to get lined up, but it sounds like you definitely got a mismarked set. Talk to Shawn, he'll straighten things out for you I'm sure.

  • kpflyingv

Posted May 22, 2006 - 12:39 PM

#7

Thanks, I'll talk to him.

  • kpflyingv

Posted May 22, 2006 - 03:50 PM

#8

I did call Shawn and he was great in helping me resolve the issue. :busted: It was something simple that I was doing wrong.

They fit perfect, it's just that the nut installing them was a little loose! :banana:

Thanks again Shawn!!!!! :ride:

  • cowboyona426

Posted May 25, 2006 - 09:54 PM

#9

Glad to hear you got it sorted out :ride: You can send your "thank you" to me via PayPal :banana:





Related Content

 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.