Gas Cap Vent


8 replies to this topic
  • Punisher660

Posted May 17, 2006 - 08:21 AM

#1

OK , I know this is a wierd one.....

I pulled my cas cap vent hose and replaced it with one of the short, stubby units that have the billet cap piece.

After riding for about 20 min, it popped off....purchased another (different brand) and the exact same thing happened. I made sure it was on tight, but its as if the vent is not allowing preassure to escape.

Anyone else ever have this problem?

  • GlobalWarmer

Posted May 17, 2006 - 08:26 AM

#2

After losing two I gave up. I switched to a one way hose snaked through my head. It doesn't work all that great either. I still have gas all over my fender.

  • Punisher660

Posted May 17, 2006 - 08:36 AM

#3

That is what I had originally, but I put a Scotts Stabilizer on w/ a sub mount, so now I can't get the hose to fit under it an into the head area. :ride:


Its good to see that I am not alone on this.

  • R_Little

Posted May 17, 2006 - 10:27 AM

#4

I have the same problem.

Can't keep those hose thingys on my bike.

The damper is in the way of a hose.

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • unkle_george

Posted May 17, 2006 - 11:18 AM

#5

I rode with a guy once who'd swear at least once every ride when he's squeeze the tank in a tight section and blow his brand new plug off into space.

  • Rider1958

Posted May 17, 2006 - 11:28 AM

#6

Heh - this has happened to me twice now, only had the billet piece (and hose) for two weeks. Seems it is common to fall off, after reading replies here.
I thought the instructions said to zip-tie the hose in place, but I disregarded. Am now thinking super glue on the hose-to-tank connection....

  • Punisher660

Posted May 17, 2006 - 11:49 AM

#7

I wonder if the problem lies with the gas cap?

  • andy666

Posted May 19, 2006 - 09:47 AM

#8

I had one of those mini vents on my bike as well.I noticed on a hot day that the tank would hold a lot of pressure.Testing the vent it didn't vent very well so I went back to the stock one when it would hold pressure I could smell gas and the bike ran differant .

  • Conan_'dale

Posted May 19, 2006 - 12:15 PM

#9

Yep, I bought the 15.00 billet cap 1st ride out it was gone. Deep in the woods I rode back to the truck while gas spilled out my cap.

Anyone out there have a solid fix for this? Drill a hole in the cap to allow more ventillation? I have a long tube down my frame but unless I really tighten down the cap it will spill out at the cap threads.

Anyone :ride:




 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.