'05 WR450 REAL Bad stalling problem ... !!HELP!!


3 replies to this topic
  • cali450

Posted May 01, 2006 - 11:48 AM

#1

I unloaded my bike at Cal city about 3 months ago to go riding with my buddies. My bike started fine, I let it warm up a little, and started to take off to turtle hill (a.k.a. Ant hill) when I noticed my bike kept backfiring and trying to stall. It seemed to want to sputter and stall most the higher up through the gears I went. My buddies gave me all the advice they had in their arsenals but to no avail. I tried cleaning the carb, the air filter, the spark plug, checked the tank, went all through the electrical, I'm at a loss . I spent the whole day working on that bike while my buddies were out. I still can't seem to get rid of the problem, could use some help....... That desert trip had somewhat of a happy ending.....I drank all their beer for leaving me at the trucks. :crazy: :ride: :ride:

  • Indy_WR450

Posted May 01, 2006 - 12:56 PM

#2

Go to our jetting post and rejet your bike following the trend on everyone's set ups, and eliminate the AIS :crazy:

http://www.thumperta...t=230021&page=1

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • odonnks

Posted May 01, 2006 - 03:26 PM

#3

Can we assume the bike ran well in the past?

  • Stiletto_72

Posted May 01, 2006 - 04:42 PM

#4

Did your air fuel screw fall out?




 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.