650l cutting out


2 replies to this topic
  • Tim Foley

Posted April 16, 2006 - 07:04 PM

#1

My 93 650L cuts off while riding after it warms up. I know its not a fuel problem. I cannot seem to get a reading through the pulse generator so i believe that is the problem. How do you test the Cdi unit? Better yet is it located in the battery box?

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • captb

Posted April 16, 2006 - 07:39 PM

#2

My CDI went out on my 93 650L, I could let it idle and if I tapped on the CDI or wiggled the connector it would miss and cut off, tried twisting the spade connectors to fit tighter but a pin connector was loose in the CDI, mine acted up more when hot.

  • mpd

Posted April 18, 2006 - 01:50 AM

#3

My 96 had the same problem. The CDI box is probably bad. I swapped it out with one from a bike being parted out. Result. Two years and not a single problem. $35.





Related Content

Forums
Photo

93 xr650l Restoration Project by Zigster


Dirt Bike   Make / Model Specific   Honda   XR600/650
  • 17 replies
Forums
Photo

Fell Off Trailer by usafxr


Dirt Bike   Make / Model Specific   Honda   XR600/650
  • Hot  43 replies
Forums
Photo

Wiseco 101MM Spark Knock Low Engine Temps by imandrewparks


Dirt Bike   Make / Model Specific   Honda   XR600/650
  • 7 replies
Reviews

Honda XR650L 2017 by Chris.GVS


Honda XR650L 2017
  • - - - - -
  • 0 reviews
Reviews

Honda XR650L 2016 by Chris.GVS


Honda XR650L 2016
  • - - - - -
  • 0 reviews
 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.