HELP!! poss. TORS

7 replies to this topic
  • stjoetalon

Posted April 11, 2006 - 08:09 AM


I have lurked here for a while now and just stayed in the shadows. But now I need help. I have complete faith in your collective intelligence!

Enough of the butt kissing. Here is my problem...

I bought an 04 YFZ 450. It has a YZ426 swap on it. The bike runs great everywhere in the rev range. That is until I let completely off the throttle. Then it dies. There are no wires going to the throttle. The only wires going to the carb are for the TPS and it is a 3 wire plug. There is a red anodized plate on the bottom of the carb. Im not sure what that replaced.

Where would the TORS go on the carb? Any suggestions as to what I need to do? It is time to go ride and this is FRUSTRATING ME!!

  • kskyles

Posted April 11, 2006 - 08:35 AM


That red anodized plate on the bottom might be a Factory R&D Lightning accellerator pump cover.

My bike came with one that the previous owner put on it. There should be some markings on it to identify it.

  • stjoetalon

Posted April 11, 2006 - 11:06 AM


Yeah, it is a Factory Pro cover. I took the carb off and am now trying to check the jetting sizes. But I dont have a clue where to start. Is there a breakdown of these carbs anywhere? Where are the jets at? Maybe I shouldnt be messing with this and I should take it somewhere. But funds are limited and I take great pride in working on my own stuff.

  • clark4131

Posted April 11, 2006 - 12:00 PM


First things first...are we dealing with a quad or a motorcycle? If it's a quad, you might be better served by the boys on the quad forum, they may have a little more firsthand knowledge. Regarding the carb, at the very bottom of the carb, there should be a 17mm drain plug. Directly underneath it you can access the main and the pilot. Next to them is the starter jet, but you have to remove the entire float bowl to access it. Lastly, what is a TORS?...SC

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • stjoetalon

Posted April 11, 2006 - 09:51 PM


It is on a quad, but none of them seem to know what I need. Half of them are still asking me why I even swapped it(I didnt).

I took a crash course today in carb rebuilding. I cleaned all the jets and passages and made sure there was no clogs or dirt ANYWHERE. I dont remember off the top of my head what all the jet sizes were. I wrote them down, but they are in the truck. Ill get them in the morning. I know the pilot jet was 45 and I "think" the main was 72. The other fuel jet was i "think" 64. Again Ill double check in the morning.The air jets were 100 and 200.

So I put it all back together and it didnt fix anything. Still runs great everywhere but Idle. No dead spots or hesitation anywhere in the rev range. Throttle response is quick and not a hint of stumble. Only Idle...

The only thing electrical coming off the carb is the TPS. Nothing on the throttle.

  • jbrooks26

Posted April 11, 2006 - 09:58 PM


Stupid question maybe, but did you try the idle screw?? It is the black knob on the side of the carb. It will have a spring attached to it and it will run to the cable side of the carb and turning it in (clockwise) will increase the idle speed. Hope this helps.


  • stjoetalon

Posted April 12, 2006 - 04:26 PM


Not stupid at all. In fact it is the first thing I went for. It didnt seem to do ANYTHING!! But when I rebuilt the carb, the adjustment screw was working just fine.

Im stumped.

The TORS goes from the throttle and the carb to where?? What actually controls it? Does it go to the rev box? I am trrying to find out how this works. I dont know if the guy used the rev box frrom the 426 or the stock 450. Is there a way to identify it?

AAAAHHHHH!!!! It is driving me nuts!

  • jbrooks26

Posted April 12, 2006 - 05:37 PM


I don't know what you mean by TORS. However, we ran across a similar situation with the idle screw on an 02 WR 426 earlier this month. It turned out that the throttle shaft had jumped out of the TPS sensor and it was held out enough that the idle screw did not contact the throttle cam on the cable side of the shaft. Pull the plastic cover off of the right side of the carb, it is where the cables connect. You will be able to see the idle screw and check to make sure it is contacting the cam. Hope this helps.



Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.