another oil leak on my 426

No replies to this topic
  • 2000YZ426dude

Posted April 06, 2006 - 06:19 PM


so i fixed the problem i had with the decompression bolt but thinking that was the oil leak problem i had but it wasn't. oil seems to be leaking either outta front of the head gasket or exhaust ... ran it for a little bit seen drip of oil off the exhaust flange and running down the front of engine... so i dunno what causeing that not sure anyone had this oil leak problem again... i recently changed the oil in it and its little bit above full but i doubt thats the problem..

Related Content


Thinking about Yamaha 250... by Arctic Pride

Dirt Bike   Special Interest Forums   Pro Racing
  • Hot  491 replies

First Hare scramble tips by dhend8

Dirt Bike   General Dirt Bike Forums   General Dirt Bike Discussion
  • Hot  33 replies

2016 YZ450 by CaptainKnobby

Dirt Bike   Dirt Bike Technical Forums   Suspension
  • Hot  59 replies

Chubby dad, looking at bikes , First trip to the orange/black forum ! by Slow_ride

Dirt Bike   Make / Model Specific   KTM   250-530 EXC/MXC/SXC/XC-W/XCR-W (4-Strokes)
  • Hot  28 replies

Michigan Motocross Tires by 288yz450

Dirt Bike   Dirt Bike Regional Discussion   North
  • 1 reply

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.